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About This Manual

The DIAdem: Data Analysis and Report Generation manual describes the 
structure of DIAdem as well as how to use the DIAdem functions to load 
data, to run analyses, to generate reports, and to compile all the functions 
into a script.

Read the Getting Started with DIAdem manual to familiarize yourself with 
DIAdem. Read the DIAdem: Data Analysis and Report Generation manual 
for more information about the functions and features in the DIAdem 
panels. While you are working in DIAdem you can refer to all functions, 
variables, and commands in the DIAdem help.

The DIAdem manuals are available in the Portable Document Format (PDF 
format) on the DIAdem CD.

Conventions
The following conventions appear in this manual:

<> Angles indicate a key you press to perform a function, for example, <Ctrl> 
for the control key.

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This symbol denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options.

italic Italic text denotes emphasis, new terms, a cross reference, or an 
introduction to a key concept.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, formulas, sections of code, programming examples, and syntax 
examples. This font is also used for the proper names of disk drives, paths, 
directories, programs, subprograms, subroutines, device names, functions, 



About This Manual

DIAdem: Data Analysis and Report Generation x ni.com

operations, commands, variables, controls, events, methods, filenames and 
extensions, and code excerpts.

monospace bold Bold text in this font denotes the messages and responses that the computer 
automatically prints to the screen. This font also highlights command lines 
that are different to other examples.
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1
Working with DIAdem

DIAdem is the National Instruments software for analyzing and 
documenting data from various sources. You navigate in various data types 
and data storages to drag and drop the data into DIAdem. In DIAdem you 
view the data to choose which data you run mathematical analyses on. You 
present calculation results in a report. If you frequently use one method to 
evaluate data, you generate a script that automates your evaluations in 
DIAdem.

DIAdem Panels
DIAdem consists of several panels. Each panel deals with a particular type 
of task. If you want to record data in a report, you use at least two panels. 
Use DIAdem NAVIGATOR to load data from databases and from files and 
DIAdem REPORT to display the loaded data in a report. Switch panels 
using the panel bar, which is always visible on the left of the screen.

You obtain data from the Data Portal, which links all the panels. DIAdem 
VIEW, DIAdem ANALYSIS, and DIAdem SCRIPT can modify data and 
store the results in the Data Portal.

DIAdem SCRIPT links all the panel functions in scripts. You can use 
scripts to generate your own applications that process your tasks 
automatically.

If LabVIEW is installed on your computer, you can start it by clicking the 
LabVIEW button in the panel bar.

DIAdem CLIP and DIAdem INSIGHT are external programs that offer you 
special analysis and report functions. You can use DIAdem CLIP to 
compare videos and test data that are recorded simultaneously, and 
DIAdem INSIGHT to display measured data as shading and/or 
deformation on a 3D model.

Panel:
DIAdem NAVIGATOR
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DIAdem User Interface
When you select a DIAdem panel, the user interface changes for quick 
access to the functions you want. Each DIAdem panel has its own group 
bar to the right of the panel bar. Click a function bar button in the group bar 
and select the function you want when the function bar opens. The 
workspace also changes with the DIAdem panel and displays a folder 
hierarchy or a worksheet. Each panel has its own Toolbar and shortcut 
menus, which contain frequently used functions.

To generate a report, select DIAdem REPORT in the panel bar. Select the 
2D axis system group bar to open the function bar with the predefined 2D 
axis system definitions. Click the 2D axis system with frame button in this 
function bar. The function bar disappears and DIAdem REPORT inserts a 
framed 2D axis system into the worksheet.

In the worksheet you can resize the axis system and move it around as 
required. Double-click to open the axis system dialog box and define a 
curve. In the first dialog box level you can set which data channels to 
display or the display mode. Special settings like axis scaling are one dialog 
box level below.

You can use the shortcut menu to change the presettings for the functions 
in the function bars. For example, if you often calculate the arithmetic mean 
and the standard deviation, select DIAdem ANALYSIS. Click the 
Statistics group bar to expand the function bar. Right-click the Statistical 
characteristic values button. Select Default setting in the shortcut menu. 
Click All off in the dialog box and select the two characteristics Arithmetic 
mean and Standard deviation. Click Change. Now click the Statistical 
characteristic values button, and the dialog box is preset with the 
arithmetic mean and the standard deviation.

The bottom function bar is the same in all the panels. You can assign scripts 
to this function bar to use functions that you write in all the panels.

Report Wizard
The DIAdem Report Wizard helps you to generate your own reports. In the 
Report Wizard, you select data, define the curve, and select the layout for 
the axis system. DIAdem uses your settings to generate the report, which 
you can add comments to and illustrate with graphics in DIAdem 
REPORT.

Function Bar
2D Axis Systems
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In DIAdem REPORT and DIAdem VIEW, you open the Report Wizard by 
clicking the Report Wizard button in the Toolbar or by pressing <Ctrl-W> 
in any panel. In the DIAdem General settings, you can disable the Report 
Wizard so it does not appear automatically when the program starts. 

Use the LabVIEW DIAdem Connectivity VIs to record LabVIEW 
measurements directly in a DIAdem report. The LabVIEW VIs open 
DIAdem, write the acquired data into the DIAdem Data Portal, and start the 
Report Wizard. The LabVIEW DIAdem Connectivity VIs are on the 
DIAdem CD, and you can download them from the NI Web site. 

DIAdem Help
DIAdem help gets you started with DIAdem and helps you use functions 
and automate your tasks. DIAdem help offers you procedures and dialog 
box help for each panel, as well as references to functions, commands, and 
variables.

A procedure is a step-by-step description of the solution to your task. 
Procedures can solve anything from basic tasks to special tasks. Complete 
the steps to learn how to work with the described functions. 

Dialog box help explains parameters for each dialog box, to help you use 
the functions correctly. References indicate more detailed explanations and 
related topics. You access dialog box help in any dialog box by clicking the 
Help button.

The function, command, and variable references list DIAdem commands 
and variables, Calculator functions, and special script functions for 
DIAdem VIEW and for user dialog boxes. For example, the help page of a 
command includes the command syntax, the command parameters with the 
value range, and a sample line.

DIAdem help provides examples of data analysis and report and script 
generation. The examples demonstrate simple solutions as well as complex 
applications. You can access the examples from the DIAdem Help menu or 
from online help pages containing related contents. For instance, DIAdem 
loads the data and the report layout automatically for a report example. 
Press <Esc> to stop an example. 

The example descriptions contain the names of the files used, which you 
can use as a basis for your own solutions. Copy the example files into 
another folder or load them into the appropriate DIAdem panel.
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NI License Manager
The NI License Manager helps you manage your NI software product 
licenses. To work with the complete version of DIAdem, click the Activate 
button and enter your serial number to activate your license. Now you can 
upgrade your evaluation version to a complete version without reinstalling 
DIAdem, and you can add new DIAdem elements.

The NI License Manager only enables functionality that is included in your 
license. For example, your license might not allow you to use 3D functions 
in DIAdem REPORT and DIAdem ANALYSIS. The buttons in the 
function bars are dimmed if the 3D functions are not included with your 
license. You must purchase another DIAdem package to access the 3D 
functions. 

When you purchase a new DIAdem package, select ?(Help)»Activate 
License to register the license. The NI License Manager dialog box 
appears, where you can enter the necessary details. Restart DIAdem to 
activate your license.
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2
Loading and Saving Data

DIAdem NAVIGATOR loads and saves your data. You navigate data files, 
file folders, and databases to find external data. You load data into the Data 
Portal, which manages all internal data. The data are arranged in channels, 
each displaying a data series. All DIAdem panels work with the channels 
in the Data Portal.

Loading External Data
DIAdem NAVIGATOR displays external data as a hierarchical structure. 
You can navigate data on your computer, on other drives on the network, 
and on all registered databases. Use the function bar to select the type of 
data storage you navigate in. Drag and drop the required data into the Data 
Portal.

You can select file-based and server-based data storage in the DIAdem 
NAVIGATOR function bars. If you select file-based data storage, DIAdem 
displays the data files on your computer drives or on the network. If you 
select server-based data storage, DIAdem displays the data of the registered 
databases.

To load DIAdem data, click DIAdem 9 files in the function bar for file-
based data storage. All the drives registered on your computer appear in 
DIAdem NAVIGATOR. Open the folder with the data you want. Drag and 
drop the data into the Data Portal. DIAdem copies the contents of the file 
into the Data Portal and lists all the channels contained in the file.

DIAdem automatically uses the associated loading procedure for the data 
type. If DIAdem cannot automatically load a file, you can specify the 
loading procedure. For example, if you want to load an earlier LabVIEW 
file in the ASCII format, right-click the file and select Load with from the 
shortcut menu. Select ASCII Import in the dialog box to import the 
LabVIEW data.

When you browse through a database, you can load channels and channel 
groups by dragging and dropping them into the Data Portal. When you 
browse through the folders on your computer drives, you also can load data 
files by dragging and dropping them. DIAdem displays selected channels, 

DIAdem NAVIGATOR

DIAdem Data
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channel groups or files that you can load into the Data Portal, with a blue 
background.

For example, select Selective loading in the shortcut menu to load single 
channels from a TDM file. Click the plus signs to view all the channels and 
channel groups in this data file. Select the channels you want and click 
Load. DIAdem loads the selected channels and adds the channels from the 
default group in the Data Portal. 

You can use filter settings to limit the number of files listed in DIAdem 
NAVIGATOR. Select View»Filter settings to open the dialog box for filter 
settings. For example, to view all files called Test from a certain date, enter 
the name test.* and the date saved.

In the DIAdem NAVIGATOR Configuration, you can specify which data 
storage DIAdem loads when the program starts. 

Registering Data Storage
The data storage manager displays all the external data storages available 
in DIAdem. You can configure, delete, and select the available data storage 
to load the data storage into DIAdem NAVIGATOR. You also can register 
new data storage in the data storage manager.

To register new data storage, select File»Change data storage. The data 
storage manager appears with the registered data storage, in a hierarchical 
structure. For example, select the data storage type SQL for a database. 
Double-click New data storage to register the new SQL database. Enter a 
name and the necessary settings. 

The data storage available in the function bars have predefined names in the 
data storage manager, for example, SQL Example for ODBC/SQL data. 
Do not delete the predefined data storage. You can modify the configuration 
of the predefined data storage to have frequently used data quickly at your 
disposal. For example, if you want to change the registered SQL database 
for the SQL/ODBC data, right-click SQL Example in the data storage 
manager. Select Properties and switch databases.

Supported Data Storage
DIAdem supports many file formats and databases. The data storage 
manager and the dialog box for loading procedures contain information 
about which data the current installation of DIAdem can load.
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DIAdem Data
DIAdem uses the TDM format to save the properties and the numeric data 
in various files with the same filenames. DIAdem saves the data properties 
in a text file with the filename extension .tdm, and the numeric data in a 
binary file with the filename extension .tdx.

Use the DIAdem 9 files (*.tdm) button in the File-based data storage 
function bar to load DIAdem data. DIAdem NAVIGATOR displays only 
data files with the filename extension .tdm. DIAdem reads the properties 
from the TDM file and loads the associated data from the TDX data file 
with the same name.

DAT Data
Click the DIAdem 8 files (*.dat) button in the File-based data storage 
function bar to load data from earlier DIAdem versions, DIA/DAGO or 
DIA-PC.

Before Version 8.1, the DAT format was the standard DIAdem format. In 
the DAT format, DIAdem saves the data properties as text in a header file 
with the filename extension .dat. DIAdem saves the numeric data in one 
or more binary files to take up the least amount of disk space. One data set 
can include several binary files, for example, files with the filename 
extension .w16 or .r48.

DIA/DAGO saves the descriptive data in a header file with the filename 
extension .dat and the numeric data in binary files, the same way as 
DIAdem 8.

LabVIEW Data
Use the LabVIEW files (*.lvm) button in the File-based data storage 
function bar to load LabVIEW data. DIAdem NAVIGATOR displays only 
data files with the filename extension .lvm. DIAdem reads the LVM file 
header and loads the data accordingly. LabVIEW saves descriptive 
information such as the delimiter used, the start value and the step width of 
the x-channel, and the actual values in a file.

Earlier LabVIEW data files have the filename extensions .lvd or .txt. 
These ASCII files only contain the actual values. Select Load with»ASCII 
Import in the DIAdem NAVIGATOR shortcut menu to load these files.

Use the LabVIEW DIAdem Connectivity VIs in LabVIEW to exchange 
data directly with DIAdem. These VIs can start DIAdem directly, to write 
acquired data straight into the Data Portal. The LabVIEW DIAdem 

LabVIEW Data
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Connectivity VIs are on the DIAdem CD, and you can download them from 
the NI Web site.

Use the LabVIEW DSC module data button in the Server-based data 
storage function bar to open a database that the LabVIEW Datalogging and 
Supervisory Control (DSC) Module has generated. In addition to the 
measurement data, the LabVIEW DSC Module saves recorded data about 
the monitoring run, alarms that occur, and control tasks executed. 

VI Logger Data
Use the VI Logger data button in the Server-based data storage function 
bar to load data from a VI Logger database. VI Logger saves measured 
data, including the record data, in the database. 

Lookout Data
Use the Lookout data button in the Server-based data storage function 
bar to load data from a Lookout database. Lookout saves data from various 
sources and saves record data with the measured data. You can accelerate 
access to a large database by specifying a time interval for which you load 
data into the Data Portal.

ASCII Data
Use the ASCII files (*.asc, *.txt, *.csv) button in the File-based data 
storage function bar to import ASCII data. A wizard helps you to analyze 
the data to be imported. For example, you specify whether a file contains 
text, whether the values are organized in blocks or channels, and whether 
empty lines occur.

In the wizard preview, you check the settings, which you then save in a 
configuration file with the extension .stp. To import another ASCII file 
with the same structure, specify this configuration file in the wizard.

Excel Data
Use the Excel files (*.xls) button in the File-based data storage function 
bar to load Excel data from Excel 97 and later. A wizard helps you to 
analyze the data to be imported, similar to the ASCII wizard. You specify 
whether the file contains several table sheets and where text is located. In 
the wizard preview, you specify text as a channel name, comment, or unit. 
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You check the settings, which you can save in a configuration file with the 
extension .stp. To import another Excel file with the same structure, 
specify that configuration file in the wizard.

ASAM Data
Use the ASAM-AOP data button in the Server-based data storage 
function bar to load data from ASAM-compliant databases using the 
ASAM-ODS Protocol (AOP). The Association for Standardization of 
Automation and Measurement Systems data model saves values and 
descriptive metadata in a hierarchical structure.

If you use commands for communicating with ASAM databases in a script, 
use the ASAM data service. The ASAM data service navigates, reads, and 
writes in ASAM Transport Format (ATF) files and ASAM-compliant 
databases. Select File»ASAM data service to open the ASAM data 
service.

ODBC/SQL Data
Use the SQL/ODBC data button in the Server-based data storage 
function bar to load data from Access, Oracle, or ADO databases. Use SQL 
(Structured Query Language) commands to access an ODBC (Open 
Database Connectivity) database. DIAdem can also access data with OLE 
(Object Linking and Embedding) and with ADO (ActiveX Data Objects) in 
client-server architecture, and in Web-based applications.

Binary Data
Use the function File»DAT files»Import via header to import binary data. 
To import the data, you create a header file containing information about 
the data set and the data channels. Click Execute in the dialog box to load 
the channels into the default group in the Data Portal according to the 
header information. Instead of making all the header entries again, you also 
can load an existing header file and modify it for your binary file. 

Crash Test Data
DIAdem can load Crash test data from the vehicle safety area in the EGV 
file format based on ISO DTR-13499, and in the MME format according to 
ISO-MME (TS 13499). To load EGV or MME data, you must register the 
appropriate GPI file filter by selecting Settings»Desktop parameters»

SQL/ ODBC Data
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GPI-DLL registration. Load the function library egvload.dll for the 
EGV format and gfsmme.dll for the MME format, from the folder 
..\diadem\addinfo. Refer to Appendix B, GPI Interface, for more 
information about the GPI interface. 

Special Data Formats
You can extend DIAdem to include other data formats not familiar to 
DIAdem. Table 2-1 lists special data formats for which DIAdem provides 
GPI file filters for importing external data. The GPI file filters are in the 
..\diadem\addinfo folder and at the NI Web site. You register GPI file 
filters by selecting Settings»Desktop parameters»GPI-DLL 
registration. When you restart DIAdem, you can load files in these special 
formats by dragging and dropping them, or by selecting File»Open or 
Load with in the shortcut menu.

Editing Internal Data in the Data Portal
The Data Portal manages data that you load from DIAdem NAVIGATOR. 
Every panel in DIAdem works with internal data. The Data Portal contains 
data channels, time channels, and text channels. The Data Portal structures 
channels in groups and displays data properties. Internal data in the Data 
Portal is loaded only temporarily in memory. The changes you make to the 
internal data are only stored after saving in a file or a database.

Table 2-1.  Special Data Formats

Filename 
Extension File Format

GPI File 
Filters

.dbf dBASE format gfsdbase.dll

.dif ASCII format for Excel gfsdif.dll

.erg ERG format gfserg.dll

.lax LAX format gfslax.dll

Various nSoft format gfsncode.dll

.rsp RPC3 format gfsrpc3.dll

.tdf LMS format gfstdf.dll

.dat TEAC format gfsteac.dll

.wav Non-compressed wave format gfswave.dll
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Working with Channels
DIAdem organizes data in channels. A data channel contains 
measurements from a sensor; a time channel contains the corresponding 
time values. A channel is the fundamental element of DIAdem. Each panel 
in DIAdem uses channels. For example, in DIAdem ANALYSIS you select 
two channels from the Data Portal for an FFT calculation and in DIAdem 
REPORT you select two channels from the Data Portal for a curve display. 

Use channel groups to organize channels in the Data Portal. When you add 
a file by dragging and dropping the file from DIAdem NAVIGATOR to the 
Data Portal, DIAdem creates a new channel group. Channel groups help 
you prepare and describe your data for evaluation and presentation. For 
example, the channel group Emissions contains all the channels from an 
auto emissions test.

DIAdem designates the last group of channels you load from DIAdem 
NAVIGATOR into the Data Portal as the default group. The default group 
is the destination for data channels in DIAdem that you do not control, such 
as channels calculated in DIAdem ANALYSIS. For example, designate the 
channel group Emissions as the default group by selecting Set default 
group in the shortcut menu and perform a smoothing calculation for the 
channel Auto_Exhaust. DIAdem stores the resulting channel 
Y_smoothing in the default group Emissions.

You use the shortcut menu in the Data Portal to manage channels and 
channel groups. Add and delete new channels and channel groups, change 
channel names and channel group names, move channels and channel 
groups, and cut and paste channels in the Data Portal by right-clicking and 
selecting the appropriate option. You can also delete all data in the Data 
Portal.

The Structure view in the Data Portal organizes channels hierarchically into 
channel groups. The List view lists all channels at the same level and you 
can determine the properties you use to sort channels. Select Select 
Properties from the shortcut menu in the List view for the channels to 
specify which channel properties are displayed. For example, one property 
that appears in the List view is the channel number.
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Creating New Channels
You can create new channels in DIAdem in many ways. DIAdem 
NAVIGATOR creates new channels when loading data. DIAdem 
ANALYSIS creates new channels for calculation results. DIAdem SCRIPT 
creates new channels by calling copying commands or calculation 
commands from scripts.

To create a data channel manually, select Create New Channel from the 
shortcut menu in the Data Portal. For example, select Numeric from the 
Display Format menu and enter 5 as the channel length. Select the 
DIAdem VIEW panel and select Display Type»Channel Table from the 
shortcut menu. Drag and drop Channel_0 from the Data Portal into the 
channel table. Enter the values 1, 2, 3, 4, 5 in the channel table data 
fields 1–5.

Data, Time, and Text Channels
DIAdem works with three different types of channels: data channels, time 
channels, and text channels.

A data channel contains acquired values, such as the measurements from a 
sensor, calculation results, manually entered values, or values from files. 
DIAdem can use each data channel in the Data Portal as a source for 
calculating and displaying graphs.

DIAdem creates a time channel from date and time statements coded 
numerically. DIAdem specifies the time and date by calculating the number 
of seconds from the year zero to the current date and current time. A time 
channel contains time values taken during a measurement. A time channel 
is often the x-channel for the calculation and the display of the 
corresponding measurement values in the y-channels.

A text channel contains character strings stored as unicode. This allows for 
characters from all major languages, including Chinese, Korean, Japanese, 
and Arabic. You cannot perform calculations on text channels, but you can 
view text channels as tables in DIAdem VIEW and DIAdem REPORT. Use 
a text channel to record observations about data values in a data channel.
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Organizing 2D and 3D Data
DIAdem handles multiple channels individually. To display curves in 
DIAdem VIEW and DIAdem REPORT, you must use both an x-channel 
and one or more y-channels. When you drag and drop channels into a 2D 
axis system, you must select the x-channel first. If an axis system already 
contains a curve, you must select an x-channel and a y-channel to insert 
additional curves into the axis system. An axis system can display multiple 
x-channels simultaneously.

For displaying data three-dimensionally, DIAdem REPORT and DIAdem 
ANALYSIS read data in a matrix structure or a triple structure. Value triples 
have three data channels, representing x, y, and z values. One matrix 
contains an x-channel, a y-channel, and many z-channels. There must be as 
many z-channels as there are values in the y-channel. The z-channels must 
be the same length as the x-channel.

Editing Data Properties
Engineering software such as LabVIEW or CVI saves data properties and 
comments with measurement values. A data property for a data set includes 
the author and the date; for a channel group, includes the measurement 
name and comments; and for channels, includes the data type and the unit.

The Data Portal displays data properties in the properties area at the bottom 
of the Data Portal. If the Data Portal does not display the properties area, 
open the properties area by dragging it vertically from the bottom of the 
Data Portal. When you click on the root name in the Data Portal, the data 
set properties appear in the properties area. When you click on a group or 
a channel in the Data Portal, the group or the channel properties appear in 
the properties area.

Double-click property fields to edit them. For example, enter Engine 
Test in the Register text1 property field. Read-only channel properties, 
such as maximum length, and monotony, appear dimmed in the properties 
area. Changeable properties, highlighted in white, include name, comment, 
and unit for the different data. You can add custom properties using the 
shortcut menu.
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Saving and Exporting Internal Data
You can save the entire data set in the Data Portal or save channel groups 
or individual channels. DIAdem saves data where you specify by dragging 
and dropping the data into a folder in DIAdem NAVIGATOR. When you 
drag and drop the data onto an existing file, DIAdem adopts the filename 
and can overwrite the file. Save all the data channels in the Data Portal by 
selecting File»Save.

You can selectively save single channels in a data file. Select the channels 
you want to save and drag and drop them to the folder in DIAdem 
NAVIGATOR where you want to save them.

You can export data in the DAT format for other applications which can 
import DAT files. For example, export data in the DAT format to analyze 
these data with videos in DIAdem CLIP. To export data in ASCII format 
select File»DAT files»Storage Parameters and change the type of data to 
ASCII. If you then save data in DAT format, DIAdem creates an ASCII file.

To exchange data with ASAM applications and software, export data in the 
ASAM data format by selecting File»ASAM data service and by using the 
scripting features in DIAdem. You also can use SQL commands in DIAdem 
SCRIPT to export data to SQL databases.

Export data into the Excel format to evaluate your data in Microsoft Office. 
The Excel Export Wizard helps you transform the data structure of the Data 
Portal into an Excel spreadsheet.
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3
Analyzing Data with 
Mathematical Functions

You can use DIAdem ANALYSIS to analyze data in the Data Portal with 
mathematical functions. The dialog boxes for the standard mathematical 
functions guide you through the calculation so you do not have to enter a 
formula. You select only the input data and make the settings you want. 
Use the Calculator to define and calculate your own formulas. For complex 
calculations that are repeated, you can write scripts. Save your results in 
data channels or in variables.

Using Standard Functions
DIAdem has extensive libraries of standard mathematical functions in 
several function bars in DIAdem ANALYSIS. The functions include basic 
mathematics like differentiation, signal analysis like FFT, and 3D analysis 
like isoline calculations.

To use a standard function, click the associated button. You select the 
calculation settings in the dialog box that opens. For example, if you want 
to smooth data, select Curve Fitting and click Smoothing. Drag and drop 
the data channel to be smoothed from the Data Portal into the dialog box. 
Specify the smoothing width. If you have used the smoothing function in 
your current work session, the channel containing the last calculation 
settings appears in the dialog box.

DIAdem stores the calculation result in the default group of data channels. 
You specify the default group in the shortcut menu of the Data Portal 
hierarchical structure. If you select Store result in original channel in the 
function dialog box, the function stores the result data in the original 
channel(s). If you call another standard function, by default, DIAdem 
applies the function to the results of the last calculation. You can use all the 
data channels in the Data Portal in calculations. The DIAdem ANALYSIS 
workspace shows you which calculations you have run with which data 
channels.

DIAdem ANALYSIS

Smoothing
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Standard functions work with one or more data channels. If a standard 
function processes several data channels, for example, the Averaging 
function, a question mark appears in the channel selection field. Select all 
the channels you want in the Data Portal and drag and drop all the channels 
into the channel selection field.

The functions you can use depend on which options you have in your 
DIAdem installation and license. Functions not included or enabled in your 
installation are dimmed in the DIAdem interface. You can obtain additional 
function libraries from NI.

Calculating Formulas in the Calculator
Use the Calculator to analyze data with your own formulas. In the 
Calculator, you can run calculations on data channels and generate new 
data channels. You can calculate single values, save values in variables, 
and request variable values.

Open the Calculator with the DIAdem ANALYSIS Toolbar button shown 
on the left.

Entering Formulas
Enter your formula in the Input box using the keyboard and the Calculator 
keys. DIAdem displays the status or the calculated result in the result line.

A formula consists of the assignment target, the delimiter, and the 
calculation instruction.

Assignment target := Calculation instruction

You usually enter a data channel as the assignment target. However, you 
also can calculate a single value and assign the single value to a variable. 
In the calculation instruction you use operations to link data channels or 
variables. The tabs at the bottom of the Calculator have numeric operations 
like sine functions, Boolean operations like AND, and text operations like 
text length.

For example, if you want to calculate the sine values for a data channel, 
insert the sine function into the Input box by double-clicking sin(arg) 
on the Numeric Operations tab. The insert sign in the Input box is 
automatically set in the argument section of the sine function, so you can 
double-click the data channel you want and move it from the Channels tab 
into your formula.

Calculator
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In the Calculator, always use a decimal point as the decimal separator and 
enclose strings in quotation marks ("...").

Note To use the operations, channels, and variables tabs in the Calculator, click the 
Extended button.

Calculating with Data Channels
To divide the second data channel by the first data channel in the 
Calculator, for example, enter the following formula in the Input box:

Ch(#) := Ch(2)/Ch(1)

DIAdem divides each value in the second data channel by the 
corresponding value in the first data channel. If the data channels are 
different lengths, the result channel is the same length as the shorter data 
channel.

The pound sign (#) on the left of the formula stores the result in the next 
free data channel. You can also enter the number or name of the result 
channel:

Ch(3) := Ch(2)/Ch(1)

Ch("Result") := Ch(2)/Ch(1)

If the data channel you specify already exists, DIAdem overwrites the 
values in it.

Calculating with Variables and Single Values
In the Calculator, you can store the values in variables, use variables in 
calculation instructions, and request variable values. These examples show 
how to enter these three alternatives for the auxiliary variable R1 in the 
Input box, for example:

You assign the result of the square root of 8.391 to the variable R1.

R1 := Sqrt(8.391)

Enter a question mark after the variable name to request the value. The 
value is displayed in the result line.

R1?

Multiply every value in the third data channel by the R1 variable and store 
the result values in the next free data channel.

Ch(#) := Ch(3)*R1
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Tip To calculate a formula without saving the result, enter the calculation instruction 
in the Input box and a question mark at the end. The Calculator shows the result in the 
Result box.

Calculating in Scripts
Use scripts to automate complex calculations that you use repeatedly. In 
scripts, you can calculate standard functions or create your own formulas. 
A script is a VBS file that DIAdem processes row by row. To enter the 
following examples, generate a new script in DIAdem SCRIPT and enter 
the sample rows. Refer to Chapter 5, Automating Sequences, for more 
information about scripts.

Calling Standard Functions
In scripts, you can use all the standard mathematical functions available in 
DIAdem. Use the Call command to call standard functions. For example, 
to smooth the entire data channel 6 with a smoothing width of 12, and save 
the result in data channel 7, enter the following line in your script:

Call ChnSmooth(6,7,12,"maxNumber")

Creating Your Own Formulas
In scripts, you can also calculate your own formulas. For example, to divide 
the second data channel by the first data channel, enter the following line in 
your script:

Call FormulaCalc("Ch(3) := Ch(2)/Ch(1)")

Use the Call command to call the Calculator function FormulaCalc. 
Enclose the formula in quotation marks and use the same syntax you use 
for entering formulas in the Calculator.

Assigning Single Values
In scripts, you also can assign values to variables. You define the single 
value assignment with an equals sign. For example, to assign the square 
root of 8.391 to the auxiliary variable R1, enter the following line in your 
script:

R1 = Sqrt(8.391)

Tip If you enable the recording mode in the DIAdem SCRIPT Toolbar, DIAdem records 
the standard functions you have called, as well as the formulas you have calculated in the 
Calculator, with the complete syntax.

DIAdem SCRIPT
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Using Variables
DIAdem provides three kinds of variables: program variables, auxiliary 
variables, and user variables. Refer to the Using Variables section of 
Chapter 5, Automating Sequences, for more information about variables.

Program Variables
Use program variables to set parameters for a command in a script. You set 
these parameters in the same way as you make settings in the dialog box for 
a standard function. The SmoothWidth program variable specifies the 
smoothing width for the ChnSmooth command in the standard function 
Smoothing.

Program variables can contain the result of a standard function. For 
example, the StatArithMean variable contains the arithmetic mean of 
a data channel when the characteristic statistical values are calculated.

Several program variables are included on the Special Variables tab at 
the bottom right of the Calculator. These program variables contain 
information on the loaded data channels, such as the maximum value of 
a data channel in the CMax variable.

Auxiliary Variables
Use auxiliary variables if you need a predefined variable that is not bound 
to a DIAdem command. In the Calculator, the auxiliary variables are at the 
bottom right on the Single variables and Vectors tabs. You can assign a 
value to the auxiliary variable in the Variable contents field next to the 
auxiliary variable. Double-click the name of the auxiliary variable to insert 
it into your formula in the Edit box.

Use dynamic enumeration variables as text variables to provide various 
keywords for selection, for example, the days of the week. For example, 
you define a selection list for the dynamic enumeration variable G1 in the 
G1Var.asc text file. When you click Variable contents for G1 at the 
bottom right of the Calculator, a selection box with the days of the week 
opens.

User Variables
Define user variables if your task requires a project-specific variable 
that has a clear name and special dimensions or data types. You define 
user variables in a variable stock file, which is a text file with the 
extension .vas. 
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Unlike the program and auxiliary variables, user variables are not 
automatically included with the standard DIAdem variables. First, enable 
the variable stock file by clicking Activate user variables file in the 
DIAdem SCRIPT Toolbar. You can then use your user variables in formulas 
and scripts.

Calculating with Invalid Values
During measurements, disturbances might occur in the sensors, causing 
incorrect values. In DIAdem you can declare these outliers as invalid 
values. In DIAdem, invalid values are called NoValues. To mark a value 
manually as NoValue, overwrite the value with NoValue in the DIAdem 
VIEW channel table. Standard functions exclude NoValues from 
calculations and the report in DIAdem REPORT does not display 
NoValues, as is shown in Figure 3-1.

Figure 3-1.  Measured Signal with Distortion and NoValues (left) and Result 
of a Classification (right)

You can use NoValues to eliminate entire ranges of a data channel, not just 
single values. For example, if you want to eliminate values that are greater 
than ten in the second data channel, because you know that the sensor used 
does not return higher values, enter the following formula in the Input box 
of the Calculator:

Ch(2) := Ch(2)+((Ch(2)>10)*NoValue)
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The Boolean request Ch(2)>10 returns 0 or 1. Multiplication by 
NoValues produces either 0 or NoValues. The result of the addition with 
the data channel is either the original channel value or NoValue. This 
replaces all values greater than 10 with NoValues.

This formula uses the following calculation rules for NoValues:

1. If one of the terms in a calculation operation is a NoValue the result is 
also a NoValue.

10 * NoValue = NoValue

10 + NoValue = NoValue

2. Multiplication and division by zero is the exception. If one of the 
factors is 0 the result is also 0.

0 * NoValue = 0

0 / NoValue = 0

NoValue / 0 = 0

Tip With the NoValues function in the Basic mathematic functions bar, you can delete 
NoValues in data channels or replace them by linear interpolation of the neighboring 
values.

Function Libraries
DIAdem includes a library of standard mathematical functions for 
analyzing your data. These functions are arranged by category in the 
DIAdem ANALYSIS function bars:

• Basic Mathematical Functions

• Curve Fitting Functions

• Signal Analysis Functions

• Statistics and Classification Functions

• 3D Analysis Functions

• Crash Analysis Functions

Basic Mathematical Functions
The Basic mathematic functions bar includes basic functions like sorting, 
normalizing, differentiation, peak search, and RMS calculation.

For example, if LabVIEW has only stored the sensor signals of your 
measurement, you do not have the time channel you need if you apply 
standard mathematical functions or display measurement data in DIAdem. 



Chapter 3 Analyzing Data with Mathematical Functions

DIAdem: Data Analysis and Report Generation 3-8 ni.com

Use the Generate time channels function to calculate the corresponding 
absolute time data, including the date. If you need a relative time channel 
from the beginning of the measurement, use the Generate data function.

Curve Fitting Functions
The Curve fitting functions bar includes functions like smoothing, 
envelope curve calculation, regression, approximation, spline calculation, 
and linear mapping. You can use the various functions to calculate a curve 
from a series of points. The curve reflects the original set of points as 
closely as possible according to specific criteria.

Use the Linear mapping function to recalculate the signals from two 
measurements with different time channels to a common time basis. Select 
one of the two time channels as the common time basis, and DIAdem 
interpolates and extrapolates the missing values.

Signal Analysis Functions
The Signal analysis functions bar includes Fast Fourier Transformation, 
digital filtering, frequency-weighted acceleration, and order analysis, 
which you use to check vibrations for frequency characteristics.

Fast Fourier Transformation (FFT)
Use FFT to transfer signals from the time domain to the frequency domain 
and back. For example, each button you press on a telephone makes a 
different sound, each of which consists of two sine oscillations. The 
exchange receives this tone and can detect which number you have dialed. 
In the time domain, the sound you create when you dial nine is difficult to 
distinguish from number five. The exchange runs an FFT on the received 
sound, because the sounds can be clearly distinguished in the frequency 
domain.

In DIAdem you can calculate the FFT for one time signal, the Inverse FFT 
for retransformation from the frequency domain into the time domain, the 
FFT for two time signals—the autocorrelation or the cross correlation, for 
example. The autocorrelation checks a signal for periodic characteristics by 
moving a copy of the signal along the signal on the time axis. The cross 
correlation uses the same method to check two different signals for 
similarities.
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The third/octave checks the volume in the frequency domain, not the exact 
frequency distribution in the signal. The third/octave analysis sums up the 
amplitude values in the FFT in standardized logarithmic frequency 
intervals, as Figure 3-2 shows.

Figure 3-2.  Third Octave Analysis of a Signal, Each Octave Consists of Three Thirds

Digital Filters
With the Digital filter function, you can attenuate or amplify selected 
frequency characteristics of a time-related signal. You can choose from 
various filters, like lowpass, bandpass, and bandstop, which only transfer 
certain frequency characteristics of the signal. The allpass filter, which lets 
through all the frequencies, is for signal delay and correcting phase 
distortion. You can use the various filters as IIR filters and FIR filters.

If, for example, a high-frequency distortion signal interferes with the actual 
measurement signal, you can filter out the distortion. To do this, enter the 
highest frequency in the undistorted part of the signal as the limit frequency 
for the lowpass filtering mode. The lowpass filters out all the distortion 
frequencies above this limit.

1 2 4 8 16 31.5 63 125 250 500 1000 2000 4000 8000
Frequency [Hz]

0.001

0.01

0.1

1

10

A
m

pl
_P

ea
k

50 63 80 100 125 160 200 250 315 400 500
Frequency [Hz]

0.001

0.01

0.1

1

10

Am
pl

_P
ea

k

Octave
Third

Amplitude

Octave Frequencies

Third Frequencies



Chapter 3 Analyzing Data with Mathematical Functions

DIAdem: Data Analysis and Report Generation 3-10 ni.com

Frequency-Weighted Acceleration
The functions in Frequency-weighted acceleration are for calculating the 
extent to which measured vibrations affect the human body, in vehicles and 
at the workplace. For example, you can test the extent to which vehicle 
vibrations affect drivers by mounting various vibration sensors on the seat 
and analyzing the acceleration signals measured using the 
Frequency-weighted acceleration function.

Order Analysis
The Order analysis functions compare the frequencies in a signal to a 
reference frequency. The calculated order gives the multiple from the 
measured signal to the reference frequency. For example, the second order 
means that the analyzed frequency is double the reference frequency. As 
shown in Figure 3-3, you can run order analysis in the time domain or in 
the frequency domain.

Figure 3-3.  Order Analysis in the Frequency Domain (above) and in the 
Time Domain (below)

Order analysis is for analyzing noises and vibrations that are measured in 
engines and engine components. In engine acceleration tests, the relation 
between the vibration and the RPM is more important than the vibration 
frequency over time.
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Statistics Functions
The Statistics functions bar has the functions for calculating the 
characteristic statistical values, like mean, quantile, and dispersion values. 
For example, you are testing the pressure resistance of cement. You run 
pressure tests on 25 blocks and measure the pressure under which the 
blocks crush. From the test results, you can calculate the arithmetic mean, 
the standard deviation, and the lowest and highest pressure. DIAdem stores 
the calculated characteristic values in a data channel and in the appropriate 
program variables, StatArithMean, StatDeviation, StatMin, and 
StatMax. You can enter these variables as text in DIAdem REPORT, so 
you can always record the latest characteristic statistical values in your 
report.

Classification Functions
The Statistics functions bar includes classification functions for 
determining frequency distributions for measured values. DIAdem divides 
the value range into classes, and counts how many measured values each 
class contains.

For example, if you want to compare series of test rig engine tests and 
driving engine tests. You select the required oil changes as the criterion. 
You count the oil changes per thousand kilometers and classify your results. 
Figure 3-4 presents the counts as curves and the classification results as a 
bar graph.

Figure 3-4.  Classifying Two Test Series
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Compound classification classifies two related data channels 
simultaneously, not just one data channel. The result of compound 
classification is a 3D matrix. You can use Reducing classification if you 
want to classify one or more data channels that correspond to the signal, not 
just the signal itself.

Rainflow Classification
Rainflow classification tests signals, in particular strain-time functions for 
special events like overshooting strain levels or strain changes.

If you want to test the duration of a spring, you prepare a test schedule that 
subjects one hundred springs to vibrations ranging from 10 Hz to 10 kHz. 
You count the number of strain runs until the spring breaks. In the rainflow 
matrix, you enter the runs in relation to the vibrations. You can display the 
results as a matrix.

3D Analysis Functions
Use the 3D analysis function bars to display your measurement data 
three-dimensionally. Figure 3-5 shows the characteristic field of an engine. 
DIAdem calculates contours and the boundary curve from the measured 
engine data.

You can organize 3D data as triples or matrices in DIAdem. DIAdem runs 
Contour calculations with data in matrices or triples. For 3D displays such 
as matrices, contours, or waterfall displays, DIAdem needs the matrix 
structure, and it needs the triple structure to display a 3D curve. The 3D 
basic functions include functions for converting the triple structure into the 
matrix structure, and vice versa.
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Figure 3-5.  Input-Output Map with Isolines for Engine Performance and Fuel 
Consumption over RPM and Densification

Crash Analysis Functions
The Crash analysis functions bar contains functions for analyzing 
measurement data from vehicle safety tests. You can use the functions to 
calculate standardized injury criteria. For example, use the Head Injury 
Criterion to assess head injuries, the Neck Injury Criterion for the neck 
area, the Viscous Criterion for the chest area, and the Tibia Index for the 
lower leg area.

The calculations are in accordance with the current SAE, ISO, and NHTSA 
specifications. For digital phaseless filtering, you can choose from CFC60, 
CFC180, CFC600, CFC1000, and FIR100.

The example Crash Evaluation Based on the MME Standard shows an 
analysis of test data for vehicle safety, with a report. You can start this 
application example in the DIAdem help. This example uses a script to 
guide you through the analysis of a front or side impact in three steps. 
Figure 3-6 shows the report for the head acceleration in a frontal impact.
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Figure 3-6.  Crash Evaluation of a Frontal Impact
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4
Displaying Data in Graphs

DIAdem provides several panels for displaying your data. Use DIAdem 
VIEW to view and process data. Document and present data with DIAdem 
REPORT. Compare measured data to simultaneously recorded video 
sequences with DIAdem CLIP. Project measured or simulated data onto 
a model of the test object with DIAdem INSIGHT. 

Viewing and Editing Data
You use DIAdem VIEW to view and edit the data in the Data Portal. Curves 
in 2D axis systems give you an overall view of your data. You examine the 
curves with a curve cursor, zoom curve sections, and delete or replace 
curve points. You list data, time, and text channels in channel tables where 
you can view and edit single values. If you modify curves or edit channels, 
DIAdem stores the changes in the Data Portal.

Designing Worksheets
You can include axis systems and channel tables in one worksheet, to see 
the data on the curve and the related numeric values at a glance. The 
function bars have templates for splitting the worksheet into varying 
numbers of sections in different positions.

For example, if you want to display your data as a curve in an axis system 
and list the numeric values in a channel table, divide the worksheet into two 
areas. Click Axis systems/channel table horizontal in the second function 
bar from the bottom, Predefined screen partitioning. DIAdem inserts an 
axis system at the top and a channel table at the bottom.

To display a curve, select the x-channel and the y-channel in the Data 
Portal. Click the data channel you want DIAdem to use as the x-channel, 
for example, Time. Then press <Ctrl> and click the data channel you want 
DIAdem to use as the y-channel, for example, Pressure. Drag and drop 
this channel pair into the axis system. DIAdem VIEW displays the pressure 
over time as a curve.

DIAdem VIEW

Screen Partitioning
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For a numeric data list, select the channels you want in the Data Portal. 
Drag and drop the channels into the channel table. DIAdem VIEW lists 
each channel in a column, with the channel name as the heading.

To define one area as an axis system, right-click the area and select Display 
type»2D axis system in the shortcut menu. You can also use the shortcut 
menu to change the display mode for an axis system, so you can view the 
displayed channels in a channel table. 

Editing Layouts
You can load a prepared layout as a view template. A layout file contains 
descriptions of all the axis systems, channel tables, and the data channels to 
be displayed. Layout files may contain several worksheets and have the 
filename extension .tdv.

Move the frame to zoom in and out on any worksheet area. You cannot 
move areas. To add new areas, split an area using the shortcut menu, or 
select different worksheet partitioning with more areas. If you select 
worksheet partitioning with fewer areas, the definitions for the surplus 
areas are deleted. If you select predefined worksheet partitioning, DIAdem 
deletes all the definitions in the displayed worksheet.

Which options are available in the DIAdem VIEW shortcut menu depends 
on where you right-click. For example, to insert another worksheet, 
right-click the worksheet tab. Select Managing worksheets from the 
shortcut menu. In the dialog box that appears, you can add, delete, rename, 
and change the order of the worksheets.

To transfer the current view of your data to DIAdem REPORT, click 
Transfer to REPORT in the DIAdem VIEW Toolbar. DIAdem REPORT 
generates a new worksheet with the axis systems and tables in the same 
layout as in the DIAdem VIEW worksheet.

Viewing Data as Curves
Use axis systems for an overall view of your data. If two data channels of 
a curve are not the same length, the curve is as long as the shorter data 
channel. Double-click the axis system to open the Display dialog box, 
where you add, modify, or delete curves.

You can change the y-axis scaling to compare curves that have different 
y-value ranges in one axis system. Click 1  system [%] in the Systems 
shortcut menu to display the y-axis with percentages.

Transfer to REPORT
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To show more legend, drag the dividing bar to the left. The legend contains 
the y-channel name and a checkbox that is the same color as the curve. The 
legend can display other channel properties such as extreme values or the 
cursor coordinates. To configure the legend, click Select properties in the 
axis system shortcut menu.

Analyzing Curves
Each axis system has a graphic cursor, which you move along a curve with 
the mouse. The standard graphics cursor is a crosshair cursor with three 
settings: freely movable, following the curve, or jumping to minimum 
values or maximum values.

For example, to examine the maximum values on a curve, select Maximum 
values cursor in the Toolbar. To open the coordinate display, click 
Coordinates. Move the graphic cursor along the curve and the crosshair 
jumps from one maximum value to the next. The coordinate display shows 
the x and y-values of each maximum value.

If one axis system has several curves, the graphic cursor only moves along 
the active curve. To specify the active curve, click the checkbox for the 
curve in the legend. If you have several axis systems in your worksheet, the 
graphic cursors move along the same value ranges in the other axis systems.

Zooming Curves
Select the band cursor or the frame cursor to zoom and to scroll curves. 
You set the width of the band cursor or the frame cursor to specify the zoom 
depth. The narrower the band cursor, the more the section is enlarged. You 
enable and disable zooming and scrolling in the axis system Toolbar.

For example, if you examine a section of a curve, and you want to see the 
entire curve at the same time, you create two axis systems with the same 
curve definition. One of the axis systems displays the whole curve and the 
other axis system zooms a section of the same curve. Click Band cursor in 
the DIAdem VIEW Toolbar, and click Zoom, dynamic in the Toolbar for 
the second axis system. If you now move the band cursor within the 
overview axis system, the zoomed axis system displays the section of the 
curve inside the band cursor.
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Editing Curves
You also can edit curves in the axis systems. For example, if a curve has 
erroneous sections or outliers, you can replace the erroneous curve points. 
The delete, copy, and interpolation functions only affect curve points that 
are marked with flags.

Click Band cursor in the DIAdem VIEW Toolbar to select a curve section. 
Set the band cursor to a width that encloses the vertical lines of the curve 
section you want. Click Set flags in the axis system Toolbar to select all the 
curve points in this section of the active curve. Press <Shift> and click Set 
flags, to select the points on all the curves in this section.

Click Flags: Delete data points in the axis system Toolbar to delete 
selected curve points or curve sections. Select Settings»Flag parameters 
to specify whether deleted curve points are deleted from the data channels 
or replaced by NoValues.

Click Flags: Copy data points in the axis system Toolbar to copy selected 
curve points or curve sections. In the Data Portal, DIAdem generates a new 
x-channel and a new y-channel for each curve.

Click Flags: Interpolate points in the axis system Toolbar to interpolate 
selected sections of the active curve. Select Settings»Flag parameters to 
specify whether DIAdem applies linear interpolation or interpolates with a 
spline function. The calculated values are stored in the y-data channel of the 
active curve.

Note If a deleted section contains NoValues, you must mark these curve points with flags, 
to interpolate the section.

You also can select several sections to delete, to copy, or to interpolate all 
the marked curve points. Click Set data point and flag to mark single 
points with the crosshair cursor in the axis system Toolbar.

You can delete the flags on the active curve, or the flags on all curves, using 
the Toolbar or the shortcut menu of the axis system. Click Global flag reset 
in the DIAdem VIEW Toolbar to delete all the flags in the Data Portal.

Curve Points
Select
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Editing Data in Channel Tables
Use channel tables to display and edit data channels, text channels, and 
time channels. The channel table displays channels columnwise. The table 
heading includes the channel properties such as the channel name and the 
channel length. You can select a column for removing channels or deleting 
channels from the table.

Click a data field to delete or to overwrite the value or the text. Double-click 
a data field to edit the value or the text. If you select several data fields in a 
column or in neighboring columns, you can edit the data block.

Using the channel table, you can fill a newly generated channel in the Data 
Portal with values. Use the shortcut menu in the Data Portal to define a new 
channel, as described in the Creating New Channels section of Chapter 2, 
Loading and Saving Data. Drag and drop the new channel into the channel 
table and enter values or generate data series by clicking Generate in the 
shortcut menu of the channel table.

You also can use the shortcut menu for the channel table to modify the 
display. For example, to display other channel properties such as the 
maximum value, select Select properties in the shortcut menu. You can 
drag and drop the properties from the Data Portal properties window into 
the channel table. Select Table settings in the shortcut menu to modify the 
display of channel contents and properties such as font size.

Documenting Data
You use DIAdem REPORT to generate a report that documents 
measurement data and results. A report can consist of several worksheets 
that include axis systems, tables, text, and graphics. DIAdem displays the 
data in curves or bar diagrams in axis systems, and lists numeric data in 
tables. You can label worksheets with text and illustrate them with 
graphics.

Creating a Report
A report may consist of several worksheets with different views of your 
data. You save the structure of all the worksheets in a report, and maintain 
the links to the report data in the layout. You can reuse layouts as templates 
for similar reports.

DIAdem REPORT
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To create another worksheet, select Insert»Worksheet. In the dialog box 
that appears, you can add, delete, rename, and change the order of the 
worksheets.

Editing Worksheets
If you want to display data as curves in a 2D axis system, click Simple 2D 
axis system in the 2D axis system function bar. DIAdem inserts a 2D axis 
system into the worksheet.

To display a curve, select the x-channel and the y-channel in the Data 
Portal. Click the data channel you want to use as the x-channel, for 
example, Time. Then press <Ctrl> and click the data channel you want to 
use as the y-channel, for example, Temperature. Drag and drop this 
channel pair into the axis system. DIAdem REPORT displays the 
temperature over time as a curve.

DIAdem REPORT requires two data channels to display a curve. DIAdem 
assigns each x-value the corresponding y-value. If the two data channels are 
not the same length, the curve is as long as the shorter data channel.

If you select more than two data channels, DIAdem REPORT uses the first 
data channel you select as the x-channel for all curves. To delete a curve or 
change the display mode, double-click the curve and the dialog box for that 
axis system appears.

Editing Objects
You can position objects such as axis systems, tables, text, graphics, and 
lines anywhere in the worksheet, as well as modifying their size. To zoom 
in or out on an object, click it. DIAdem selects the object with a dashed 
frame that has small squares in the corners and on the sides. Use the squares 
on the sides, top, and bottom to change the width and height. The squares 
in the corners zoom the object in and out, without affecting the proportions. 
Press <Ctrl> at the same time, to change the size but keep the center.

You can select several objects and move, zoom, and set parameters for all 
of the objects. However, you can only modify the properties that all the 
objects in the group share. If you select an axis system and a text object, 
you cannot set parameters for the group, because the group has no common 
properties. However, if you select an axis text and a heading, you can 
change the font for both.

2D Axis System 
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You can align selected objects and scale the size of the objects. The dashed 
frame around the object group is the reference point for DIAdem. To make 
an axis system and a table the same width, click Align width in the Toolbar. 
If you have a table to the lower right of an axis system, DIAdem sets the 
width at the left edge of the axis system and the right edge of the table.

Most objects consist of several subobjects, such as axes, axis text, and 
curves. You can select and edit each subobject. You can move selected axis 
text, or double-click the text to open the dialog box and edit the text or the 
text parameters.

Displaying Objects
You can superimpose axis systems, tables, text, and graphics in a 
worksheet. The superimposed objects are visible because the backgrounds 
are transparent. To highlight a text in an axis system, select White for the 
text background.

DIAdem displays objects in the same order you insert them. The new 
objects are in the foreground. You can change the order of the objects. 
To position a new graphic behind an existing axis system, right-click on 
the graphic and select Move to background in the shortcut menu.

When you move an axis system, DIAdem does not redisplay the entire 
worksheet, it only redisplays that axis system, which appears to move it to 
the foreground. Click Redraw in the Toolbar, to display all the objects in 
the correct order.

Formatting Numeric Data
You can use format instructions to specify numeric display on axes or in 
tables. As shown in Table 4-1, you can limit the number of decimal places 
and display numbers as exponents or powers of ten.

Table 4-1.  Format Definition

Format
Format 

Definition Numeric Display

Two Decimal Places d.dd 123.46

Decimal with Exponent d.dde 1.23E+02

Decimal with Power of Ten d.ddh 1.23*102

Align Width
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Time Data Format
DIAdem formats time data with different wildcards for the day, month, 
year, hour, minute, and second. The time format definition starts with the 
# character. The number of wildcards used is the same as the number of 
places to be displayed, and wildcards in the uppercase ignore leading zeros: 

#mm.dd.yyyy hh:nn:ss 04.09.2002 12:43:09

#www, DD. T, YYYY Mon, April 9, 2002

The wildcards W and T display the day of the week and the month as text. 
You only can use format definitions for time data if the data channels or the 
variable contents are in the DIAdem time format.

Variable Formats
Use the Str function to display formatted numeric variables. For example, 
to display the current median value with four decimal places, enter the 
following line in a report:

@Str(StatMedian,’d.dddd’)@

The Str function converts the numeric contents of the StatMedian 
variable into text. The format definition d.dddd rounds off the fourth 
decimal place. For DIAdem, the @ character indicates a variable expression.

Formats with User Commands
To display data in a format that DIAdem does not recognize, define user 
commands as format definitions. You define user commands in DIAdem 
SCRIPT. Refer to the Defining User Commands section of Chapter 5, 
Automating Sequences, for more information about user commands.

Figure 4-1 displays the same data in two axis systems that have x-axes in 
different formats. The top axis system displays the time in hours, and the 
bottom axis system displays the time in days after 5,000 hours. The 
CalcRelFun user command in the UserCmdExample.vbs script 
generates the second format. The format definition for the x-axis in the 
bottom axis system includes the following command call:

@@CalcRelFun(CFV, "01.12.2001 00:00:00")@@
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Figure 4-1.  User Commands Format the Time Axis

To apply user commands when the report is updated, enter user commands 
in Settings»Layout parameters»Commands to be performed. You can 
define user commands not only to format axis systems and tables, they also 
can read information from databases and run calculations.

Editing Layouts
You save the descriptions of all the worksheets in your report in a layout 
file with the filename extension .tdr. The layout file contains descriptions 
of all objects, such as axis systems, tables, or text, and data links. You can 
alter or delete data assignments in the dialog boxes for the axis systems and 
tables.

The standard DIAdem REPORT works with channel numbers. This is 
useful if the data channels are always at the same position in the data set. 
If you do not know the data set structure, but know that the channels always 
have the same channel names, select the Name-oriented channel 
reference in Settings»Layout parameters. DIAdem then saves the 
channel names in the layout.

You can use the layout file as a template for other reports that have data in 
the same structure. In the Panel-specific settings, you can specify a 
template file as well as the start file that displays DIAdem REPORT when 
it opens. DIAdem uses this template when you create a new report by 
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clicking File»New. You can insert standard objects that every layout should 
include, like the company logo, in the template.

You can specify the page format as a ratio or a scale in DIAdem REPORT. 
Ratio-adjusted page format specifies the worksheet size as the height of the 
worksheet in relation to the width. In the print dialog box you enter the 
width of the printout, corresponding to the selected paper format. The 
standard DIAdem REPORT settings specify a ratio of 0.7 for A4 
landscape format or 0.8 for letter landscape. If you modify this ratio, you 
move the objects in your report. This is because you specify the position of 
the objects as the distance from the bottom left corner, as a percentage of 
the width and height of the worksheet.

For scaled page format, you enter a fixed height and a fixed width for your 
worksheets in Settings»Layout parameters. DIAdem always prints your 
report in the specified size, regardless of the paper format. If you select a 
scaled page layout, you can scale your axis system manually to ensure that 
DIAdem always prints the same number of units per centimeter, for 
example, 10 °C/cm.

Inserting Report Objects
In the function bars, DIAdem provides predefined objects for documenting 
your data. You can change the definitions in the function bars. The 
following objects are arranged by category in the DIAdem REPORT 
function bars:

• 2D axis systems

• Polar axis systems

• 3D axis systems

• 2D tables

• 3D tables

• Text objects

• Graphics file

Inserting Axis Systems
Axis systems display data channels as curves and bar diagrams. Use a 2D 
axis system to display velocity over time as a curve. Use a 3D axis system 
to display a characteristic diagram of engine performance over RPM and 
densification. Use a polar axis system to display the sensitivity of a 
microphone in a circle diagram.
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2D Axis Systems
Use 2D axis systems to display data channels as curves or as bar diagrams. 
The x-channel is often a time channel. You can use any other data channel 
as the x-channel, for example, the frequency of a spectral analysis.

You can combine various display types in one axis system. Use a bar 
diagram to display a statistical evaluation as a histogram. Numbers above 
the bars show the frequencies of the individual results. A horizontal line in 
the axis system represents the arithmetic mean.

If you set automatic scaling, DIAdem REPORT uses the entire data channel 
for curve display. To zoom a section, set manual scaling. Enter the first and 
last values for the x-axis and the y-axis in the dialog box for the axis system. 
DIAdem REPORT has various types of scaling, such as linear and 
logarithmic. You can scale the x-axis differently from the y-axis. To 
generate a probability network, set linear scaling for the x-axis and 
logarithmic scaling for the y-axis.

One axis system can include several curves. DIAdem automatically uses 
the data channel with the highest value range to scale the curves. You can 
define curves with the same x-channel or with different x-channels. Use 
subaxes if the axis system contains y-data channels that have different value 
ranges and different units. Each subaxis has a separate scale. Figure 4-2 
shows a separate subaxis for each test parameter in an engine test, because 
the CO emission, fuel consumption, and exhaust temperature each have 
different units. If you zoom in or out in subaxes, DIAdem REPORT adjusts 
the display of the associated curves.
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Figure 4-2.  Engine Test Evaluation with Subaxes

Polar Axis Systems
Use polar axis systems to display curves in circle diagrams. For a polar axis 
system, select two data channels from the Data Portal, the same as for a 2D 
axis system. The x-channel contains the angle and the y-channel contains 
the lengths. Figure 4-3 shows different levels of sensitivity for two 
microphones. The polar axis system shows how the sensitivity of the 
microphones, which are positioned at the axis origin, depends on the 
direction of the microphones. You can define polar axis systems as 
semicircles, quarter circles, or with any angle from 0–360°.
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Figure 4-3.  Sensitivitiy of Two Microphones

3D Axis Systems
Use 3D axis systems to display a characteristic diagram of engine 
performance over RPM and densification, as shown in Figure 3-5, 
Input-Output Map with Isolines for Engine Performance and Fuel 
Consumption over RPM and Densification, Figure 3-3, Order Analysis in 
the Frequency Domain (above) and in the Time Domain (below), shows a 
waterfall display of the results of an order analysis.

Figure 4-4 shows a combination of several display modes for a spiral in a 
3D axis system. To display the spirals as 3D curves, select three data 
channels in the 3D axis system dialog box. The arrows on the spiral are 
vectors that display the force for each point on the spiral. The xy and 
xz-planes show the spiral projections.

To change the view of a 3D axis system, rotate the axis system by resetting 
the axis definition dialog box. You can scale and label each display plane 
and specify the grid display separately. As Figure 4-4 shows, you also can 
move the display planes. To move a plane outwards, click the edge of the 
plane. The cursor changes to a triangle and you can move the plane 
outwards.
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Figure 4-4.  Vector Display of a Spiral with Projections onto the Plane

DIAdem organizes the data in a matrix structure for waterfall, surface, or 
isoline display. For these display modes, you select three data channels in 
the dialog box for 3D axis systems: one x-channel, one y-channel, and the 
first z-data channel in the data matrix. 3D display must have the same 
number of consecutive z-data channels as the number of values in the 
y-data channel. You can use the 3D analysis functions in DIAdem 
ANALYSIS to convert data channels into a matrix or a triple value.

Inserting Tables
Tables list data channels and time channels numerically. You can also 
display text channels and variable contents in a 2D table. Tables can be 
aligned horizontally or vertically.

2D Tables
Use 2D tables to list numeric data channels, time channels, and text 
channels in columns. For each column, select a channel, specify the display 
parameters, and enter a heading. You can change the order and the width of 
the columns. For long channels, you can specify the first value, the last 
value, and the step width.

Select the Automatic expand setting in the table dialog box for complete 
documentation of long channels. This defines a table that lists the channel 
contents on several pages. The button shown at the left is in the DIAdem 
REPORT Toolbar and scrolls the pages.

Next Table Contents
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You also can display single variables and vector variables in a 2D table. 
Select Variable as the data type in the table dialog box and enter the 
variable name. If you enter the single variable CurrDate in the dialog box, 
the current date appears in the top line of the table. If you enter the CD 
vector variable, the units of all the channels in the Data Portal appear in the 
table column.

3D Tables
Use 3D tables for numeric display of the matrix structure of 3D data. Enter 
the x-data channel, the y-data channel, and the first z-data channel of the 
matrix structure in the dialog box for 3D tables, the same way as for the 3D 
axis system. Figure 4-5 shows how the 3D table assigns each xy-value pair 
the relevant z-value.

Figure 4-5.  3D Tables Assign Each XY-Value Pair the Relevant Z-Value

The 3D table can display the entire data matrix or a section. You enter 
display parameters like font and display mode separately for the x, y, and 
z-values, not columnwise. To display 3D data in triple structure, list the 
three data channels in a 2D table. Each line has a triple.

Inserting Text
DIAdem REPORT provides the text cursor and the text object for 
generating text. With the text cursor, you generate one-line text such as 
headings, and with the text object you generate multiline text with different 
formats.
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Text can include formula expressions and DIAdem variables, which 
DIAdem updates along with the rest of the report. For example, to display 
the current time, insert the CurrTime variable in a text object:

@CurrTime@

The @ characters indicate to DIAdem which parts of the text are variables. 
You can include user variables as well as the program variables and 
auxiliary variables. Refer to the Using Variables section of Chapter 5, 
Automating Sequences, for more information about variables.

One-Line Text
Use one-line text for short headings or comments.

Click the Text button in the DIAdem REPORT Toolbar to activate the text 
cursor. Click the worksheet with the text cursor and enter, for example, the 
heading shown in Figure 4-6 Ribs Left. You end the text entry by 
clicking another position in the worksheet. If the text cursor is activated and 
you press <Enter>, DIAdem generates a new line, where you can enter 
Dummy front left, Hybrid III 50%.

To change one-line text, for example, double-click the text. Modify the text 
and the font attributes for that text in the dialog box. You can rotate one-line 
text. Click one of the squares at the corners of the selected text and rotate 
the text to the right or to the left with the curved arrow.

Figure 4-6.  Crash Test Report with Heading and Text Field

Text
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Multiline Text
Use the text object to generate multiline text with different formats.

To generate a multiline text, click Text object in the Text function bar. 
A white field appears in the worksheet. Double-click the text object and 
enter your text or import a prepared text file in ASCII, RTF, or HTML 
format. The text object editor offers functions for formatting single words 
and sections. Set up your text structure using list points, enumeration, 
tabulators, paragraphs, and tables.

You define the font size differently for text objects than for one-line text or 
axis labels. You specify the text size in absolute terms for the text object but 
in relation to the worksheet for one-line text. If you zoom one-line text, you 
enlarge the text itself. However, if you enlarge a text object, you only 
change the layout, not the size of the text.

Inserting Graphics and Lines
Use graphics to include a diagram of a test stand or to insert a company logo 
into your report. You can use the Graphics file function bar to load 
graphics in various formats. You can position graphics behind axis systems 
and tables, because these objects have transparent backgrounds.

When you insert graphics, DIAdem generates a link to the graphics file. 
DIAdem saves the link with the path definition in the layout. If you load a 
layout and DIAdem displays a gray frame instead of a graphic, DIAdem 
was not able to find the graphics file in the folder specified. Double-click 
the graphic and correct the path definition.

Use frames to highlight a text field or a heading in the report. To display 
a frame, click the Frame button in the toolbar. The cursor appears as a 
square with arrows at the corners. Drag out a frame and position the frame 
where you want it in the worksheet.

You can also turn a frame into a line. A horizontal line is a frame with a 
height of zero, and a vertical line is a frame with a width of zero. To create 
a vertical line from a frame, enter the same position for the left and the right 
edges in the dialog box for the frame.

Load Graphics
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Linking Measurement Data with Videos and Models
With DIAdem CLIP and DIAdem INSIGHT, you analyze your 
measurement data together with videos and 3D models. You use 
DIAdem CLIP to compare simultaneously recorded videos and 
measurement data from a test. You use DIAdem INSIGHT to project 
measurement data onto a 3D model of the test object.

Analyzing Data and Videos Together
Use DIAdem CLIP to analyze data and videos that were simultaneously 
recorded. DIAdem CLIP displays data as curves in axis system areas and 
videos in video areas. DIAdem CLIP links each data point in a graph to the 
appropriate video frame. Use the Player bar to automatically play the scene 
or use the line cursor to inspect each point of the curve.

Note DIAdem CLIP is an external module you must install separately from DIAdem.

Creating Scenes
In DIAdem CLIP each scene contains axis systems and video areas, to 
analyze data and videos. The Data Window on the right of the DIAdem 
CLIP workspace organizes video files, data files, and picture files.

The prepared layout in the workspace contains one video area, one axis 
system area, and one picture area. For example, to create a scene of a frontal 
crash test, click AVI-Files in the Data Window. Drag and drop the 
frontcrash.avi video file into the layout. Click DIAdem-Files in the 
Data Window and drag and drop the frontcrash.dat file into the layout. 
DIAdem CLIP displays a curve for each data channel.

To resize and move a video area or an axis system area in the layout, click 
the edge of the area. Drag the small square blocks to adjust the size or drag 
the area frame to where you want to have the area. To delete a selected area 
or axis system, press <Del>.

Evaluating Scenes
Use the Player functions in the DIAdem CLIP Toolbar to gain an overview 
of the entire scene. Playing an entire scene helps you spot general trends 
and behaviors in your tests. The Player bar functions are similar to the 
buttons on the control panel of a video recorder. To loop the front crash test 
scene continuously, press Play continuously in the Player bar.

DIAdem CLIP
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Use the line cursor in the axis system to pinpoint specific curve points to 
analyze a specific area of a scene. DIAdem CLIP displays the video frame 
for each corresponding curve point. For example, if an unexpected result 
occurs in the front crash test, you can move the line cursor to related data 
points. DIAdem CLIP cues the video to the video frame closest to the data 
point in question.

Synchronizing Videos and Data
DIAdem CLIP synchronizes videos and curves using the time channel from 
the data set and the frame rate of the video. If the data acquisition rate is 
greater than the frame rate, DIAdem CLIP displays the same video frame 
for multiple data points. For example, if the data acquisition rate is 100 kHz 
and the video frame rate is 1,000 frames per second (1 kHz), the video 
frame changes for every 100th data point in a curve.

If videos and axis systems do not have the same time range, you can specify 
the time range where they overlap. In DIAdem CLIP, the time range you 
specify is called the active segment. DIAdem CLIP only displays changing 
video frames when you move the line cursor inside the active segment.

To enter the starting point and ending point of the active segment, select 
Synchronization parameters from the video area shortcut menu. 

Using Accept cursor position, you can use the position of the line cursor 
to designate the starting time for the video, or the starting point or the end 
point for the active segment.

When analyzing a scene using the player bar, use the metronome to 
determine whether DIAdem CLIP displays the entire video or only a part 
of the video. If you drag and drop the metronome onto a video area, 
DIAdem CLIP plays the entire video and the line cursor follows along 
inside of the active segment of the axis system. If you drag and drop the 
metronome onto an axis system, the line cursor follows along the entire 
length of the axis system and the video plays only inside the active segment.

Saving Scenes, Presentations, and Layouts
When you save a scene, DIAdem CLIP saves the layout with links to data 
files, video files, and picture files. The file has the filename extension.cis.

You can load a prepared layout as an empty template for frequent 
evaluations of similar tests. A layout determines only the type and number 
of areas and axis systems, including their size and position. To load a 

Synchronization 
Parameters

Accept Cursor
Position

Metronome
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layout, select File»Open layout to open the layout library. To save the 
layout of the current scene in the layout library, select File»Save layout.

The MediaBuilder option enables you to save scenes as presentations. 
A presentation file combines all data, video, and picture files into a single 
.cip file. Select File»Save and choose .cip from Data Type to save a 
presentation file. Use the FREE Media Player to view presentations on 
computers without DIAdem CLIP. You can also password-protect a 
presentation to avoid alterations.

Adding Measurement Data, Videos, and Graphics
The Data Window lists directories containing video files, data files, and 
picture files. To add directories to the Data Window, right-click in the Data 
Window and select New Directory from the shortcut menu. To delete a 
directory, right-click on the directory and select Delete from the shortcut 
menu.

DIAdem Data
DIAdem CLIP uses DIAdem data files in the DAT format. To use other 
data sources in DIAdem CLIP, you must convert the data into the DIAdem 
.dat data format in DIAdem NAVIGATOR. Refer to Saving and 
Exporting Internal Data in Chapter 2, Loading and Saving Data, for more 
information on data conversion.

If you add a data file or data channel to an axis system, DIAdem CLIP 
automatically uses the time channel of this data file as the x-channel. If 
more than one time channel exists in this data file, you can select the 
x-channel you want to use. A downwards pointing arrow appears in front 
of the x-channel.

Each axis system area has a legend. You can turn on and off the legend by 
selecting Legend on/off from the shortcut menu. A colored block in the 
legend represents the curve in the axis system with the same color. To delete 
a curve from the axis system, select the curve symbol in the legend and 
press <Del>.

DIAdem CLIP scales the y-axis automatically to the value range of all data 
channels and the x-axis to the value range of the time channel. To enlarge 
curve segments, you can select scaling and zooming from the shortcut 
menu. Use manual scaling to focus on specific data ranges in the y-axis of 
your axis system. Use the zoom function to focus on a specific time range 
of the x-axis.

Axis Legend
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Videos
DIAdem CLIP uses video files digitized in AVI (.avi) and MPEG (.mpg) 
formats. Each video area contains only one video. When you drag and drop 
a new video into the video area, DIAdem CLIP replaces an old video with 
the new one. Create additional video areas to display multiple videos. You 
can use the zoom function to zoom videos for a more detailed view.

Graphics
DIAdem CLIP uses pictures saved in the JPEG (.jpg) or BMP (.bmp) 
format to insert the company logo or a picture of the test object. The 
pictures enhance the appearance of your presentation. Each picture area 
contains only one picture. You can zoom a picture to display a detailed 
view.

Linking Data to a Test Object
With DIAdem INSIGHT, you project your measurement data onto a model 
of the test object as color shading or deformation. You load a grid model of 
a test object and assign the measurement data to the 3D model. You can 
examine the model from all sides. The DIAdem INSIGHT user interface 
works the same way as DIAdem CLIP.

Note DIAdem INSIGHT is an external module you must install separately from DIAdem.

Creating Scenes
The key object of a scene in DIAdem INSIGHT is the model of the test 
object. 3D grid models are made up of many grid points, which can 
represent sensor positions. You link the model points with measurement 
data from individual sensors. DIAdem INSIGHT displays the data on each 
grid point as color shading or deformation. The display reflects the 
changing measurement data on the model.

For example, to analyze the effects of an air conditioner on a driver, drag 
and drop the model of the dummy file dummy.fem from the Data Window 
into the DIAdem INSIGHT layout. To link measurement data with the 
model, open the data tab in the Data Window. Double-click on the data set 
klimadummy to see all the data channels. Drag and drop one data channel 
to a point on the model. A dialog box appears for selecting the display type, 
such as the Color. Assign additional data channels successively to other 
model points.

DIAdem INSIGHT
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Use the Player bar to display the fluctuating temperature. Red coloring 
displays heating and blue coloring displays cooling on the dummy. While 
evaluating the scene, you can rotate and zoom the model. To rotate a model, 
depress the mouse button and move the mouse. To zoom in or to zoom out 
a model, depress the right mouse button and move the mouse horizontally. 
To move the model along a coordinate axis, depress the right mouse button, 
and press <X>, <Y>, or <Z> to specify the axis.

You can display data as shading or as deformation. Use color shading to 
display the effects of temperature on a dummy, use deformation to display 
displacements of the model surface.

You can combine display types on a model. For example, display 
temperature both as color shading and deformation. To combine the display 
types color and deformation, assign the same channel twice to the same 
model point. In the ToolTip for a point, you can see which display type and 
data channel you defined for a point.

You can assign a single data channel to multiple model points. To assign a 
single data channel to multiple model points, press <Ctrl>, drag a rectangle 
over the model points, and drag and drop the data channel to the model 
points.

You can simplify assigning multiple data channels to multiple model 
points. Name the model points in a model to match the data channel names. 
DIAdem INSIGHT automatically assigns the data channels to the matching 
model points, if you drag and drop the entire data file to the model.

When you have several data files for the same model, you do not need to 
reassign the data channels to the model each time you load a new data set. 
As long as the data channels have the same sequence as the original model 
assignment, the data channel assignment to the model points remains the 
same.

If you want to delete the data channel assignment from the model point use 
Reassign a data channel in the shortcut menu. To cancel multiple point 
assignments, press <Ctrl> and drag a box around the points to select the 
model points.

DIAdem INSIGHT uses the following types of grid models:

• VRML: Virtual Reality Modeling Language format

• FEM: ANTRAS finite element model

• MOD: ANTRAS geometric model

Delete Assignment
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You can set various display and illumination features for the model area. 
Select Display from the shortcut menu to alter the settings for color 
shading, deformation, and size. Select Lighting and Light Sources from 
the shortcut menu to set the brightness and specify additional light sources 
for the model area.
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5
Automating Sequences

For recurring work sequences such as standard calculations and serial 
evaluations, you can use DIAdem SCRIPT to combine the steps into one 
script. Control structures and dialog boxes help to design scripts for various 
data sets, analysis methods, and report displays. 

Working with Scripts
The easiest way to generate a script is in the recording mode. DIAdem 
records the commands and the variable assignments for each interactive 
editing step. You can edit, test, and extend the recorded script. 

To record a script, select Script»Enable recording mode in the DIAdem 
SCRIPT Toolbar. In the recording mode, you generate script by 
interactively loading data or layouts, or running calculations. DIAdem 
SCRIPT records these actions as commands in the editor. To end the 
recording, select Disable recording mode. 

DIAdem displays the recorded script in the script editor. Save the script for 
later use. To facilitate editing, you can use functions like line numeration, 
jump instructions, bookmarks, restoring, and find and replace. The syntax 
colors distinguish between comments, commands, and variables. 

If you select commands and variables and move the cursor over them, the 
ToolTip displays parameters. If you set the indentation marker at a 
command or a variable, you can open the help page for the command or 
variable by pressing <F1>. 

To start the script that is displayed in the editor, click Run script in the 
DIAdem SCRIPT Toolbar. To run a saved script, without loading it into the 
script editor, click Execute script file. 

You can assign frequently used scripts to a button in the DIAdem SCRIPT 
function bar. The bottom function bar is available in all the DIAdem panels, 
so you can use these scripts in all panels.

DIAdem SCRIPT

Enable the Recording 
Mode

Script Function Bar in 
All Panels
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Note You can enter scripts in the DIAdem shortcut properties to run sequences 
automatically when DIAdem starts. Refer to the Starting with Parameters section of 
Appendix A, Configuring DIAdem.

Use the script debugger to find script errors. When an error occurs, the 
debugger stops at the script line with the error and displays a green marker. 
The error appears in the information area. To monitor variables in the 
information area, copy the variable from your script into the monitoring 
window of the information area. While you test the script, DIAdem 
displays the changing variable contents. You can set breakpoints at crucial 
points in your script. 

Note The debugger functions are not installed with DIAdem because they are not included 
in the license. Refer to DIAdem help for information about installing the debugger 
functions. 

Use the file overview when you edit projects with several scripts, variable 
stock files, and list files. Drag the left edge of the editor window to the right 
to open the file overview. The hierarchical display lists all the loaded files 
according to file type. Use the file overview to switch files, close files, and 
create new folders. You also can modify the syntax coloring for the various 
file types in the script editor.

To save all the settings in the file overview, select Save workspace in the 
shortcut menu. DIAdem generates a WSP file, which DIAdem links to the 
current desktop file. The Starting with Parameters section of Appendix A, 
Configuring DIAdem, explains how you start DIAdem with a desktop file 
and a prepared workspace, which loads all the files and settings you need 
for a project.

Creating Scripts
A script is a sequence of commands, variable assignments, and formula 
calculations. You use loops and branches to control the script. You can use 
comments, empty lines, and indentation to give the script a clear structure.

Calling Commands
You can use the commands from all the DIAdem functions in scripts. The 
recording mode in the DIAdem SCRIPT script editor records the command 
for each function that you call in the interface. DIAdem also includes 
commands that you can only use in scripts, such as the SQL commands for 
communicating with databases.



Chapter 5 Automating Sequences

© National Instruments (Ireland) Limited 5-3 DIAdem: Data Analysis and Report Generation

You execute DIAdem commands in the script with Call. Enter the 
parameters, like the data channels to be used and the selection terms for the 
calculation procedure, in brackets:

Call ChnPeakFind("Time","Speed","X_Peak","Y_Peak", 

5,"Max.Peaks","Amplitude")

In this example, the peak search command searches for the five highest 
amplitude peaks in the curve that consists of the Time and Speed data 
channels, and stores the results in the data channels X_Peak and Y_Peak. 

If the specified channel names recur in the Data Portal, DIAdem works with 
the data channels Time and Speed using the lowest channel numbers. You 
can add the channel group name and use Example/Time, for example. 
Select Settings»Desktop parameters»General»Unique channel names 
for a group, to ensure that your script does not return incorrect results due 
to channel names recurring in a channel group. 

You also can use the channel numbers from the Data Portal list view for the 
original channel and the result channel:

Call ChnPeakFind(3,4,5,6,5,"Max.Peaks","Amplitude")

The peak search command then uses the original channels 3 and 4 in the 
example, and stores the results in channels 5 and 6. In the recording mode 
configuration, you can specify whether DIAdem records the channel 
numbers or the channel names.

Using Variables
DIAdem variables transfer parameters to commands or accept the results of 
mathematical calculations. DIAdem distinguishes between program 
variables, auxiliary variables, and user variables. Refer to DIAdem help for 
a list of all the program and auxiliary variables. You can use VBS variables 
as well as the DIAdem variables. 

Program Variables
Use program variables to set parameters for a command in a script. If you 
use standard functions interactively, DIAdem saves your settings in 
program variables and then calls the command. For the peak search 
example described above, first assign values to the program variables 
PeakNo, PeakType and PeakSort, and then call the command:

PeakNo = 5

PeakType = "Max.Peaks"
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PeakSort = "Amplitude"

Call ChnPeakFind("Time","Speed","X_Peak","Y_Peak")

Auxiliary Variables
Use auxiliary variables if you need a predefined variable that is not bound 
to a DIAdem command. You can use auxiliary variables as scalar or vector 
values with different data types, as shown in the Table 5-1.

Assign values to auxiliary variables before you use the auxiliary variables 
in your script. To preset several auxiliary variables simultaneously, select 
Edit»Auxiliary variables to open the dialog box for auxiliary variables in 
DIAdem SCRIPT.

Use dynamic enumeration variables as text variables to provide various 
keywords for selection, for example, the days of the week. You define a 
selection list for the dynamic enumeration variable G1 in the G1Var.asc 
text file, which is in the DIAdem library folder. Load the G1Var.asc file 
into the script editor and enter the day of the week:

Monday

Tuesday

..

Sunday

User Variables
Use user variables if your task requires project-specific variables that have 
clear names and special dimensions or data types. You define user variables 
in a variable stock file, which is a text file with the extension .vas. 

Table 5-1.  Data Types for Auxiliary Variables

Data Type Scalar Vector

Boolean B1 —

Integer L1 LV1

Numeric R1 RV1

Text T1 TV1

Dynamic 
enumeration list

G1 GV1
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To access the months in the Month_ user variable, generate the variable 
stock file MyMonths.vas in the script editor, with the following definition:

Month_: A ('January','February','March','April', 

'May','June','July','August','September','October',

'November','December') <'May'>

The underscore in Month_ indicates that it is a user variable. The A after the 
colon specifies the user variable Month_ as an enumeration variable. The 
variable is preset with May. Unlike the program and auxiliary variables, the 
user variables are not automatically included in the DIAdem variable stock. 
You must activate your variable stock file MyMonths.vas with the 
UserVarCompile command at the beginning of the script, before you can 
use one of your user variables:

Call UserVarCompile("Demo\Aut\MyMonths")

VBS Variables
Unlike DIAdem, VBScript does not recognize predefined variables or data 
types. VBS variables are always data type variant, which uses different data 
types depending on what you use it for. A VBS variable reacts like a 
number when you use the variable in a calculation and it reacts like a string 
when you enter text.

Register VBS variables with the Dim instruction. The following example 
contains the registration for a numeric variable and a text variable. At the 
beginning of a script you can use the Option Explicit command to 
register VBS variables.

Option Explicit

Dim MyVariable, MyString

MyVariable = 10

MyString = "DIAdem"

Calculating Formulas
You can also use the formulas that you enter in the Calculator to calculate 
data channels and single values, in scripts. DIAdem records your formulas 
with complete syntax in the recording mode. For example, if you convert 
the Celsius data channel into degrees fahrenheit and store the result in the 
new Fahrenheit data channel, DIAdem records the following command 
line in the script editor:

Call FormulaCalc("Ch(Fahrenheit) := 

1.8 * Ch(Celsius) + 32")
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DIAdem calls the Calculator function FormulaCalc with Call and 
calculates the formula that is specified as a parameter. Refer to the 
Calculating Formulas in the Calculator section of Chapter 3, Analyzing 
Data with Mathematical Functions, for a description of formula syntax.

Controlling the Script Sequences
If you create a script in the recording mode, DIAdem works down through 
the script line by line. For the script to run dynamically, you can insert 
loops and branches.

Use loops to repeat command lines. For example, you can use a For loop to 
set the 22 variables for calculating characteristic statistic values as No. Then 
set the variables that calculate the script as Yes.

For i = 1 to 22

 StatSel(i) = "No"
Next

StatSel(4) = "Yes" ’Minimum

StatSel(5) = "Yes" ’Maximum

Call StatBlockCalc("Channel", "1-", "2")

Use branches to apply various functions in association with conditions. 
If L1 is not equal to zero, the following If...Then...Else instruction smooths 
the second data channel with a window width that depends on the channel 
length:

If L1 = 0 Then

MsgBoxDisp("No Calculation")
Else

SmoothWidth = trunc(ChnLength("Speed")/10)
Call ChnSmooth("Speed", 5, SmoothWidth)

End If

Use control commands to stop, end, or repeat your script. For example, the 
KeyWait command stops the script until the user presses a key, and the 
Pause command stops the script for a specific length of time. The 
AutoQuit command terminates the script.

Using the interaction mode, you can stop your script to work interactively 
with DIAdem. You can, for example, use DIAdem VIEW to specify a curve 
section for analysis in a script. You enable the interaction mode in scripts 
with the InterActionOn command. To end the interaction mode, click 
End interaction, which is in the Toolbar in all panels.

End Interaction
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Readability and Reusability
Scripts are easier to read and to reuse if you adhere to a few basic standards 
when you write your scripts:

• Only write one instruction per script line.

• Use comments to describe the structure of the script and the commands 
you use. Start comments with a single quotation mark and include 
them at any point in your script.

• Insert an empty line to separate sections for single functions.

• Indent the instructions for branches and loops, so the beginning and the 
end of the loop are in line and easier to recognize. This is useful for 
nested branching.

Generating User Interfaces
You can link your script to dialog boxes to select calculation methods, 
request entries, or load files. To set parameters for a standard mathematical 
function before the calculation, call the appropriate DIAdem program 
dialog box in the script. Use the DIAdem SCRIPT dialog editor to create 
user dialog boxes for making entries and specific project requests.

Calling Program Dialog Boxes
Program dialog boxes are standard DIAdem dialog boxes that you use in 
your script to set parameters for standard mathematical functions or to run 
file operations. Open the dialog box for standard mathematical functions 
with DlgOpen. The name of the program dialog box is in the DIAdem help 
page under script calls. For example, to call the selection and calculation of 
characteristic statistical values from your script, use the following script 
line:

Call DlgOpen("DlgStatBlockCalc")

Your script calls the dialog box, and you select the characteristic values you 
want, and click Execute. DIAdem calculates the characteristic values and 
continues the script.

To load files, add the following to your script:

Call FileNameGet("NAVIGATOR", "FileRead")

If DlgState = "IDOk" Then

Call DataFileImport(FileDlgFile)
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Else

MsgBoxDisp ("No file selected")

End If

The FileNameGet command opens the dialog box for loading data files in 
DIAdem NAVIGATOR. You select the data file you want in the dialog box, 
and DIAdem writes the file name into the FileDlgFile variable. If you 
click OK to close the dialog box, the script loads the file specified in 
FileDlgFile into the Data Portal.

Creating User Dialog Boxes
User dialog boxes are project-specific dialog boxes that you generate for 
entering values, requesting settings, or starting functions. Use the DIAdem 
SCRIPT dialog editor to create dialog boxes, which you save in a dialog 
box file with the filename extension .sud. You call user dialog boxes in 
the script with the SudDlgShow command. Include the dialog box name 
and the dialog box file. For example, the following call displays the user 
dialog box shown in Figure 5-1:

Call SudDlgShow("DlgEvalMain", 

"Crash_MMEEvaluation.sud")

Figure 5-1.  User Interface for Crash Evaluation
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You can use events to logically connect the elements in a user dialog box. 
Figure 5-1 shows the main dialog box for a crash evaluation, in which the 
buttons are activated one at a time after the appropriate steps. In the first 
step you load the test data and indicate whether you examine a frontal 
impact or a side impact. In the second step you evaluate the selected data 
set. In the third step you select the display mode for the results.

Defining User Dialog Boxes
To generate user dialog boxes, call the dialog editor in the DIAdem 
SCRIPT Toolbar or use the templates in the Dialog box templates function 
bar. If you need a user dialog box for channel selection, click the Select a 
data channel template. Enter a name for your dialog box definition, for 
example MyDialog.sud. DIAdem loads the template into the dialog 
editor.

The dialog box template for selecting channels contains two selection 
boxes and a Cancel and an OK button. Use the dialog editor to include other 
controls like checkboxes, tables, or ActiveX objects. Use frames, text, and 
graphics to design your dialog box. You can modify the size and position 
of the controls and align them in relation to each other.

Each control has properties that you can view and modify in the properties 
window. The properties include color, font, design, ToolTip, and tab 
sequence. The tab sequence specifies the order in which controls receive 
focus when you navigate the dialog box using using the <Tab> key.

Variables connect the controls in your user dialog box to your script. In the 
Select a data channel dialog box template, the two selection boxes are 
linked to the auxiliary variables L1 and L2. When you preset the two 
auxiliary variables in your script, the user dialog box displays the values in 
the selection boxes. If you change the values in the user dialog box, L1 and 
L2 have the new values and return the values to the script.

You must register DIAdem variables that you use in the user dialog box. 
Click Variables in the dialog editor toolbar. Click New entry to register 
variables.

Controlling User Dialog Boxes
You can control user dialog boxes in relation to events. For example, you 
can disable the OK button until the user enters values. To link a control to 
an event, select the event in the properties window and fill the appropriate 
VBS script with methods.

Dialog Box Templates

Dialog Variables
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Select an event on the Event tab in the properties window. When you 
click ..., the dialog editor opens the script editor, where you define the 
event. Click Script view on/off to switch to the dialog box view.

The EventClick event is linked to a button click. The .Enable method 
activates a control. To enable the CalculateButton by clicking the 
LoadButton, use the following VBS script:

Sub LoadButton_EventClick()

Dim This : Set This = LoadButton

CalculateButton.Enable=1
End Sub

You can save parts of the user dialog box in the catalog window in the 
dialog editor. Click Insert in the shortcut menu to copy marked controls 
into the clipboard. Then click the catalog window and select Insert in the 
shortcut menu. You save the properties and events together with the control.

Special Script Functions
DIAdem SCRIPT gives you special functions for the following:

• Defining your own functions as user commands in scripts

• Running serial evaluations in scripts

• Using DIAdem interfaces to communicate with other applications in 
scripts

• Limiting the use of individual commands to user rights, and

• Accessing objects in layout files in DIAdem VIEW and DIAdem 
REPORT

Defining User Commands
You can define several user commands in a script, which extends the range 
of DIAdem commands. You can use these user commands in Calculator 
formulas, for axis systems formats in DIAdem REPORT, and as new 
commands in DIAdem SCRIPT.

For example, if you need a special format for data display in DIAdem 
REPORT, write a user command with the appropriate instructions. The 
right column in Table 5-2 shows a trend display with plus and minus signs 
corresponding to the values in the middle column. Instead of a format 
instruction, the definition of the right column has the following user 
command:

@@TabTrend(CFV)@@
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The two @ characters show DIAdem that this is a user command, not a 
variable or a text format. The CFV or CurrentFormatValue variable 
stands for the current channel value.

Table 5-2.  List of Monthly Measured Values with Trend Display
Specified in a User Command

You define user commands as procedures or functions. Procedures can only 
include arguments, whereas the function can also return a value. The 
TabTrend user command shows a maximum of three plus or minus signs 
as text:

Function TabTrend(ByVal Value)

if Value <= -100 then
 TabTrend = "---"
elseif (Value > -100) and (Value <= -50) then
.......
elseif (Value >= 100) then
 TabTrend = "+++"
end if

end Function

For DIAdem to add your user commands to the stock of commands, you 
must register script files that have user commands by selecting Settings»
Desktop Parameters»User Commands. The TabTrend user command is 
in the registered script UserCmdExample.vbs. DIAdem saves the link to 
the script file in the desktop file. Your user commands are then permanent, 
until you delete the link or load another desktop file.
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Analyzing a Series of Files
In DIAdem SCRIPT, you can automatically analyze and document a series 
of files in a script, without loading each file separately. For example, if you 
run a long-term test that saves a result file every day, you can analyze all 
the data that is recorded in one week at the beginning of the following 
week.

To do this, you create a list file, which is a text file with the names of the 
data files for analysis. The list file must have the same name as the relevant 
script and the filename extension .lst. The list file contains the filenames 
without filename extensions.

To generate list files during recording mode, select Activate series 
evaluation in the recording mode in the DIAdem SCRIPT configuration. 
To record file types not covered in the recording mode, use the 
DirLstWrite command and copy the files into the list file.

In your script, you use a reference to the list file instead of using multiple 
file names in loading and saving commands:

Call DataFileImport("UseFileList")

If you have several different commands in your script that access the same 
list file, the order of those commands must match the order of the filenames 
that they call in the list file. For example, if you first call the 
DataFileImport command for loading data files, you must have a data 
file specified at the first position in the list file. If you then call the PicLoad 
command for loading layouts, you must have a layout file at the second 
position in the list file.

Communicating with Other Applications
You can use the DIAdem interfaces OLE, ODBC/SQL, and ASAM-ODS 
in scripts.

DIAdem exchanges data and commands with other applications through 
the OLE interface (Object Linking and Embedding). DIAdem can be the 
client as well as the server. DIAdem can use OLE to access other 
applications or to access another DIAdem. Refer to the DIAdem help page 
on The OLE Interface in DIAdem for more information.

DIAdem reads and writes to ODBC (Open Data Base Connectivity) 
databases through the ODBC/SQL interface. Use SQL (Structured Query 
Language) commands to access the ODBC databases. The DIAdem SQL 
commands can access any database that the ODBC administrator in 
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MS-Windows registers as a data source. Refer to the DIAdem help page on 
The ODBC/SQL Interface for more information.

You can use the ASAM-ODS interface (ASAM Open Data Service) for 
read and write access to ASAM-compliant data files and databases. Open 
the ASAM data service as a user interface for navigating in ASAM data. 
DIAdem has special ODS commands for accessing ASAM data. Refer to 
the DIAdem help page on ASAM Data Service for more information.

Assigning User Rights
You use the user management dialog box to organize which users have 
access to certain functions in a script. To do this, you set up password-
protected user accounts that have varying rights. DIAdem saves this 
information in a coded ADM file.

When a user starts your script, the script opens the dialog box for logging 
in. The log in includes information for DIAdem about the user account. For 
example, to limit database access, query DataExchange rights for the 
account before OLE use. DIAdem only starts the database link if the user 
has the appropriate rights. Refer to the DIAdem help page on User 
Administration for DIAdem - General Information for more information.

Accessing Objects in DIAdem VIEW
The main objects in DIAdem VIEW are worksheets, areas, axis systems, 
curves, channel tables, and columns. In your script, you can generate new 
objects and modify or delete objects. You access objects in DIAdem VIEW 
using the object hierarchy. The global object is the view object, which can 
be several worksheets long. The worksheet can be split into several areas, 
each of which contains either an axis system or a channel table, or is empty. 

The following script deletes all the worksheets in DIAdem VIEW and 
generates the new worksheet MySheet. In the new worksheet, the script 
generates the NewArea as a 2D axis system, and generates a curve in the 
axis system with the x-channel 1 and the y-channel 3. 

Call View.Sheets.RemoveAll()

Set MySheet = View.Sheets.Add("NewSheet")

Set NewArea = MySheet.ActiveArea

NewArea.DisplayObjType = "CurveChart2D"

Call NewArea.DisplayObj.Curves.Add(1,3)
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Accessing Objects in DIAdem REPORT
DIAdem REPORT objects include such things as axis systems, tables, and 
text. To access objects in DIAdem REPORT, first open, edit, and close the 
main object, and then open, edit, and close the subobject. The following 
script lines change the color of a curve in a 2D axis system:

Call GRAPHObjOpen("2DAxis1")

Call GRAPHObjOpen("2DObj3_Curve1")
D2CURVECOLOR ="Red"

Call GRAPHObjClose("2DObj3_Curve1")
Call GRAPHObjClose("2DAxis1")

To use the object hierarchy in your script, open the axis system dialog box 
by double-clicking in the axis system and pressing <Ctrl-A>. Switch to 
DIAdem SCRIPT and insert the contents of the clipboard into your script 
by pressing <Ctrl-V>. The script editor displays the commands with the 
object names and the variable assignments from the dialog box.
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A
Configuring DIAdem

Appendix A contains information about configuring DIAdem, installing 
from a network, starting the program with parameters, and the DIAdem 
folder structure.

Settings
You can configure various DIAdem properties in the Settings menu:

• In the general settings, you specify all the general DIAdem properties, 
such as the unit, the time format, or how the Report Wizard responds.

• In the panel settings, you specify which folders the DIAdem panels 
search for files in, and which start files the DIAdem panels load.

• In the memory management you specify the amount of memory space 
available in the Data Portal for internal data. This menu item only 
appears when you close all the panels by selecting Window»Close all. 

• In the log file settings, you specify whether DIAdem records only error 
messages or other messages as well. To open the log file, select 
?»View log file.

DIAdem saves the settings in the desktop file desktop.ddd. You can set 
up different DIAdem configurations for different users or projects, save the 
settings in desktop files, and load the files when you need them. 

To save the current settings in a new desktop file, click Window»Close all 
to close all the panels. Click Save desktop and enter a name for your 
desktop file. DIAdem automatically restarts when you load the desktop file.

Click Load desktop to load a desktop file. Refer to the Starting with 
Parameters section for more information about loading the desktop file.

DIAdem loads the parameter file with the desktop file. DIAdem saves the 
function bar definition in the parameter file. The parameter file has the 
filename extension .par. You can define project-related or user-related 
function bars and save the settings in various parameter files.

To create a new parameter file, copy the standard file userpar.par to the 
DIAdem folder and name the copy myparams.par, for example. Start 
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DIAdem and select Settings»Parameter file. Add the new entry 
myparams.par and delete the parameter file userpar.par. You can now 
define the function bars for your project. Generate a new desktop file to 
save your definitions. DIAdem opens your myparams parameter file with 
the new desktop file.

Starting with Parameters
You can launch DIAdem with optional parameters in order to preconfigure 
DIAdem or to start executing a script on start up. Enter the parameters in 
the properties for the DIAdem call. To change the Windows shortcut to 
DIAdem, right-click the DIAdem icon. Select Properties in the shortcut 
menu. Add the call parameters you want in the Target textbox.

Use the /D parameter to start DIAdem with a specific project desktop file. 
The desktop file contains the DIAdem settings like file paths, units, or the 
time format. To load the desktop file testrig.ddd when DIAdem starts, 
change the call to the following:

"diadem.exe" "/DC:\diadem\testrig"

Use the /C parameter to perform a command as soon as DIAdem starts. 
To run the MyScript script when DIAdem starts, change the call to the 
following:

"diadem.exe" "/CScriptStart('MyScript.vbs')"

Use the /S parameter to specify the local system folder for a DIAdem client 
in a network installation. The DIAdem client searches the system folder for 
interface files and system files required for the program start. To specify the 
system folder system when DIAdem starts, change the call to the 
following:

"diadem.exe" "/SC:\diadem\system"

You can use various parameters in one call, and you can use the same 
parameter several times. For example, to start an application on a test 
computer, change the call to the following:

"diadem.exe" "/DC:\diadem\engine1" 

"/CScriptStart('MainTest.vbs')" 

"/CScriptStart('TestReport.vbs')"

First, DIAdem loads the desktop file engine1.ddd, with the paths and 
settings set up for the project. Then, DIAdem starts the script MainTest, 
which displays the user interface for the test. When you close the user 
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interface, DIAdem stops the script MainTest and starts the second script, 
TestReport.

Folder Structure
Figure A-1 shows the three-level folder structure in DIAdem: program 
layers, structure layers, and file layers.

Figure A-1.  Folder Structure

1. The program layer is the folder that contains the program files.

2. The structure layer breaks down the files as follows:

• ADDINFO and SYMBOLS contain system files.

• LIBR contains examples and templates.

• DEMO contains user manual files.

• USER is for your own files, and is initially empty. You can create 
other folders for other users and projects.

Each DIAdem panel always searches for files on two paths: first on the 
user path and then on the library path. You can change both paths in the 
settings. When you load a file in the dialog box, DIAdem 
automatically adjusts the user path.
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3. The file layer contains files from the DIAdem panels in various 
folders:

• AUT contains scripts (.vbs), list files (.lst), variable definitions 
(.vas) and user dialog boxes (.sud).

• DAT contains data header files (.tdm and .dat) and data files 
(.tdx, .r64, .asc, .txt, and .lvm).

• GRA contains layout files (.tdr and .tdv) and graphics files 
(.wmf, .bmp, .tif, and .jpg).
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B
GPI Interface

Figure B-1 shows a diagram of the General Programming Interface (GPI), 
for which you can program your own variables and commands or data file 
filters for loading external formats. This DIAdem extension is a function 
library (DLL). Use the GPI Wizard to define framework for your function 
library. You write code for the functions you want in Microsoft Visual C++ 
(Version 6.00).

Figure B-1.  General Programming Interface

To use your function extensions in DIAdem, register the function library in 
the menu Settings»GPI-DLL registration. DIAdem saves the reference to 
the additional registered GPI-DLL in the desktop file. After an automatic 
program restart, you can use the extension the same as the original DIAdem 
functions.

Standard

Functionality
Data Filter API - New Data Filters

GPIDIAdem Extension DLL

Command API

Variable API

:

- New Commands

- New Variables

:

Provide Service Routines

Provide Functionality



© National Instruments (Ireland) Limited C-1 DIAdem: Data Analysis and Report Generation

C
Converting AUT Scripts

In DIAdem SCRIPT, you can load, edit, and run VBS scripts and AUT 
scripts from earlier DIAdem versions. The two script types have the 
following differences:

You can convert AUT scripts into VBS scripts, for example, to use the 
debugger in DIAdem SCRIPT. Start the conversion by selecting 
Script»AUT/VBS script converter in DIAdem SCRIPT.

The following is a basic description of converting AUT scripts:

• The converter deletes the semicolon at the end of an AUT script line.

• The converter splits one AUT script line with several instructions into 
several VBS script lines, so that each VBS script line only contains one 
instruction.

• The converter transforms channel operations into a call for the 
FormulaCalc() command.

• The converter does not modify Calculator operations that correspond 
to VBS functions with the same name, like abs, sin, exp, log and 
ltrim. When DIAdem runs the VBS script, DIAdem calls the VBS 
function.

Table C-1.  Differences between VBS and AUT Scripts

Script Element AUT Script VBS Script

End of line ; Line feed

Assignment := =

Calling a 
command

FileNameGet() Call FileNameGet()

Channel 
operation

Ch(2):=Ch(1) FormulaCalc

("Ch(2):= Ch(1)")

User variable Uservariable$ Uservariable_
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• To be able to convert object access of the x-axis in an axis system in 
DIAdem REPORT, for example, you must open DIAdem REPORT 
before the conversion.

• The convertor converts AUT procedures into SUB procedures. 

• The converter replaces an underscore in AUT procedure names 
with an x.

• The converter cannot convert nested procedures. You must convert 
them later.

• The convertor replaces For loops in AUT scripts with Do-While loops, 
because VBS scripts do not accept DIAdem variables as loop 
variables:

The converter inserts the comment “Step 1 or Step -1”, because 
it does not know whether the loop counts up or down.

• The converter cannot convert requests for NoValues.

• The converter adds the comment “case sensitive” to text 
comparisons because VBS scripts are always case-sensitive.

• The converter replaces all Boolean values that are not equal to zero 
with TRUE. TRUE is not automatically the value 1 in VBS scripts, 
which means that numeric calculations with Boolean values return 
different values than in AUT scripts.

Refer to the AUT/VBS converter topic in the DIAdem help for more 
information about the converter.

AUT Syntax VBS Syntax

For L1:= 1 to 3 Do

Begin

.....;

End

L1=1 

Do While L1<=3

....

Loop
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D
DIAdem File Formats

Note The Special Data Formats section of Chapter 2, Loading and Saving Data, includes 
a list of additional data formats for which DIAdem provides file filters.

Filename Extension Description

ASC, TXT, CSV Text files in ASCII format

AUT AUT script from DIAdem 8

DAT Data files from DIAdem 8 

DDD Desktop files with DIAdem settings

LST List files with filenames for series evaluation

LVD, LVM LabVIEW data files

PAR Parameter files with the function bar definitions

R64, R48, I16 Binary data files from DIAdem 8 

TDM DIAdem data files with references to TDX binary file

TDR Layout files from DIAdem REPORT

TDV Layout files from DIAdem VIEW

TDX Binary files for DIAdem data file

VBS Script files from DIAdem SCRIPT
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E
Technical Support and 
Professional Services

Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources include the following:

– Self-Help Resources—For immediate answers and solutions, 
visit our extensive library of technical support resources available 
in English, Japanese, and Spanish at ni.com/support. These 
resources are available for most products at no cost to registered 
users and include software drivers and updates, a KnowledgeBase, 
product manuals, step-by-step troubleshooting wizards, 
conformity documentation, example code, tutorials and 
application notes, instrument drivers, discussion forums, 
a measurement glossary, and so on.

– Assisted Support Options—Contact NI engineers and other 
measurement and automation professionals by visiting 
ni.com/support. Our online system helps you define your 
question and connects you to the experts by phone, discussion 
forum, or email.

• Training—Visit ni.com/training for self-paced tutorials, videos, 
and interactive CDs. You also can register for instructor-led, hands-on 
courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, NI Alliance Program 
members can help. To learn more, call your local NI office or visit 
ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.
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Grid models, DIAdem INSIGHT, 4-22

H
help, technical support, E-1

I
Installation, 1-4, A-2
Instrument drivers (NI resources), E-1
Interaction mode, 5-6
Inverse FFT, 3-8
Isoline display, 4-14

K
KnowledgeBase, E-1

L
LabVIEW data, 2-1, 2-3

LabVIEW DIAdem Connectivity VIs, 
1-3, 2-3

Layout
DIAdem REPORT, 4-9
DIAdem VIEW, 4-2
Evaluating videos and curves, 4-19
Layout transfer, 4-2

License activate, 1-4
Lines, 4-17
Loading binary data, 2-5
Lookout data, 2-4

N
National Instruments support and 

services, E-1
NI License manager, 1-4
NI support and services, E-1
NoValues, 3-6
Numeric format, 4-7
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O
ODBC/SQL data, 2-5
Order analysis, 3-10

P
Page format

Ratio preserved, 4-10
Scaled, 4-10

Panels, 1-1
Peak search,Script, 5-3
Pictures, Using in a scene, 4-21
Polar axis systems, 4-12
Presentation, 4-19
Program start

Entering desktop file, A-2
Entering system folder, A-2
Script call, A-2

Program variables, 3-5, 5-3
Descriptive statistics, 3-11

Programming examples (NI resources), E-1
Projection, Projecting data onto a 3D 

model, 4-21

R
Report

3D axis systems, 4-13
Axis systems, 4-10
Documenting results, 4-5
Editing objects, 4-6
Frames and lines, 4-17
Layout file, 4-9
Polar axis systems, 4-12
Specifying page format, 4-10
Subaxes, 4-11
Tables, 4-14
Text enter, 4-16
Text objects, 4-17

Report wizard, 1-2

S
Scene, 4-19

Combining different elements, 4-20
DIAdem data files, 4-20
Graph and videos, 4-18
Graphic files, 4-21
Grid models, 4-22
Projecting data onto a model, 4-21
Starting evaluation, 4-18
Synchronizing videos and data, 4-19
Video files, 4-21

Script, 5-1
Calculating formulas, 3-4, 5-5
Commands, 5-2
Control commands, 5-6
Create dialog boxes, 5-7
Defining user commands, 5-10
File overview, 5-2
Interaction mode, 5-6
Loops and branching, 5-6
Program start, A-2
Recording mode, 5-1
Running calculations, 3-4
Running standard functions, 3-4
Script editor, 5-1
Using standard dialog boxes, 5-7
Variables, 3-4, 5-3
VBS variables, 5-5

Signal analysis, 3-8
Digital filters, 3-9
FFT, 3-8
Frequency-weighted acceleration, 3-10
Inverse FFT, 3-8
Order analysis, 3-10
Third/Octave analysis, 3-9

Software (NI resources), E-1
Standard functions, 3-1, 3-7

3D analysis, 3-12
Calling in scripts, 3-4
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Crash analysis, 3-13
Curve fitting, 3-8
Generating a time channel, 3-7
Signal analysis, 3-8
Statistics, 3-11

Subaxes, 4-11
Support, technical, E-1
Syncronizing, Data and videos, 4-19

T
Tables, 4-14

2D tables, 4-14
3D tables, 4-15
Formats with user commands, 5-10
Multipage tables, 4-14

TDM data, 2-3
technical support, E-1
Templates

DIAdem REPORT, 1-3
DIAdem VIEW, 4-2
Report, 4-9
Script, 1-3, 5-9

Test object, Projecting data onto a model, 4-21
Text channels, 2-8

UNICODE, 2-8
Text editor, 4-16
Third/Octave analysis, 3-9
Time channels, 2-8, 3-8
Time data format, 4-8
Training (NI resources), E-1
Troubleshooting (NI resources), E-1

U
Upgrading the evaluation version, 1-4
User commands

Data format, 4-8
Defining, 5-10

User dialog boxes
Controlling with VBScript, 5-9
Defining, 5-9
Methods, Events, 5-9
Using variables, 5-9

User variables
DIAdem ANALYSIS, 3-5
DIAdem SCRIPT, 5-4

Using UNICODE characters, 2-8

V
Variables

Auxiliary variables, 3-5, 5-4
Calculating with variables, 3-5
Calculations and requests, 3-3
Dynamic enumeration variable, 5-4
Format definition for display, 4-8
GPI, B-1
In scripts, 5-3
In text, 4-16
Program variables, 3-5, 5-3
Use in tables, 4-15
User dialog boxes, 5-9
User variables, 3-5, 5-4
Value assignment, 3-4
VBS variables, 5-5

VI Logger data, 2-4
Videos

Evaluating a scene, 4-18
Using in a scene, 4-21

W
Waterfall display, 4-14
Web resources, E-1
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Z
Zoom

DIAdem VIEW, 4-3
Dynamic, 4-3
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